3rd Party API Returning: "Error: TypeError: Load failedstatus: -1"

I’m trying to connect to a 3rd party API and, while I’ve used Postman and other resources to connect to the API, I’m not able to connect with Appgyver. I’ve been pulling my hair out with this one since it seems like it’s an easy fix. Can anyone tell me if they see something out of place here?

The error:

Hi, might help to have the Chrome developer tools’ Network tab on while you make the request and inspect the error from there to get to the bottom of it.

Also is ?Style=[style] a valid query parameter for the backend?

Hi @Nate_Travers
Because you are trying to retain a set of products, have you tried “Get collection (GET)” instead of Get record (GET)?
I don’t think that any additional “HEADER*” is needed. I also didn’t see the need for any “query parameter” for this particular case.

*Maybe two key/value pair:
UserName = Account Number
Password = API Key


Thank you!
I was foolishly doing all of this in a Safari browser instead of Chrome. Once I switched to Chrome I was able to get the real error, which looks to be that CORS is not enabled. Is there a workaround? I’ve reached out to the 3rd Party but if they are unable to accommodate does that mean I won’t be able to use this API?

Hi, if it’s in fact a CORS error yes that would mean the backend provider would have to allow requests from the origin you are using.

However this error is sometimes thrown in other cases as well, just to make sure if you open the developer tools (right-click + inspect → Network tab), is the issue there also a CORS error? :slight_smile:

@Mari Yes, it is giving me a CORS error in the network tab. I’ll reach out to the admin of the API and see if they can allow these requests. Thank you for your help.

1 Like

Hey Nate, did you solve this?

I decided to go a different route so I’m not using AppGyver anymore. I’m not sure if I ever figured this out.

Too bad. Thx for your response!

what platform did you decide to use?

HI, I have the same error message and can’t connect the 3rd party API. It is likely very straight forward to put the endpoint there but it doesn’t work. I used Get Collection method with API key. Would you please see anyway to get this through? Thanks.