Access nested info in json

Hi there

I am having a hard time accessing nested information in my json when it comes to UserInappPurchases.

So one user can have many inapp purchases. While all other info is no problem to display, (I access for example FirstName like this: appVars.AppUser[0].FirstName) I don’t “find” a way to display the UserInappPurchases.

I tried several things, and that’s my last try:

appVars.AppUser[0].UserInappPurchases[0].Platfrom

that’s the json

[
{
“Id”: 38,
“Airline”: null,
“AirlineCode”: “LH”,
“AirportHomeBaseCode”: “FRA”,
“Benefits”: null,
“CalendarUrl”: null,
“CodeUserAircrafts”: null,
“CreateDate”: “/Date(1430960032857)/”,
“CrewFunction”: {
“Id”: 2,
“Code”: “FO”,
“Name_DE”: “First Officer”,
“Name_EN”: “First Officer”,
“Name_ES”: null,
“Name_FR”: “First Officer”,
“Sort”: 4,
“Stripes”: 3
},
“CrewFunctionCode”: “FO”,
“CurrentInvitedFriendCount”: 48,
“EditingTaxPlanData”: false,
“Email”: “a.xxxxxx@gmail.com”,
“FirstName”: “Andreas”,
“InvitationId”: 0,
“InvitationStatus”: 0,
“IsCrew”: true,
“IsMyInvitation”: false,
“IsUnlimitedPromo”: false,
“LastMaxStateUserFriendsInvitationDate”: “/Date(1612602300130+0100)/”,
“LastName”: “N”,
“MaxUserFriends”: 2,
“Password”: “”,
“PromoExpirationDate”: null,
“Sex”: 0,
“SharePushs”: false,
“ShareStatistics”: true,
“ShowGermanTaxFeature”: false,
“Subscribed”: false,
“TaxYear”: 0,
“UpdateDate”: “/Date(1615479356570)/”,
“UserAircrafts”: [
{
“Id”: 6,
“Code”: “B747”,
“Name”: “Boeing B747”
}
],
“UserInAppPurchases”: [
{
“Id”: 420985,
“OriginalTransactionId”: “637483918165530572”,
“Platfrom”: “Android”,
“ProductId”: “com.followme.aero.crew.1year”,
“PurchaseDate”: “/Date(1612791416553)/”,
“TransactionId”: “637483918165530572”,
“UserEmail”: “a.xxxxxx@gmail.com”,
“UserId”: 38,
“ValidFrom”: “/Date(1612134000000+0100)/”,
“ValidTo”: “/Date(1644274800000+0100)/”,
“ValidationReceipt”: “fakefake637483918165530572-2131366199”
},
{
“Id”: 431302,
“OriginalTransactionId”: “637510797531966921”,
“Platfrom”: “iOS”,
“ProductId”: “com.followme.aero.crew.lifetime”,
“PurchaseDate”: “/Date(1615479353197)/”,
“TransactionId”: “637510797531966921”,
“UserEmail”: “a.xxxxxx@gmail.com”,
“UserId”: 38,
“ValidationReceipt”: “fakefake637510797531966921-378449077”
}
],
“Version”: 749
}
]

Thanks for your help
Andreas

solved it, it was a typo in the end :skull:

1 Like

I hate typos
Typos are my nemesis

@Mendez_Holliday yeah, you don’t want to know how many hours I spent on this one