Android build does not pass splash screen, installed on emulator

I have been trying to get to a point where I can test push notification viability through Firebase/Appgyver Android. To do that, afaik, I have to actually install a build of the app instead of just using the SAP AppGyver Preview app.

I made a blank project called AppGyver Test. It has the one page it started with, and nothing else. No changes.

I have successfully followed the Android build instructions and built it 4 different times, each time incrementing the version number.

I’ve used both runtime versions 2.12.4 and 3.0.5.

I am running an Android 9.0 Emulator on my Mac, with Google Play signed in and enabled. I do not have regular access to another Android device to test on.

I drag the built .apk file to the emulator to install. It installs, and when I open it, it always just shows the splash screen (AppGyver logo) indefinitely.

I uninstall after each install / run, before installing a different build.

I’ve tried adding a “Navigate to [Homepage]” flow after the AppLaunched event in the Global Canvas on runtime 3.0.5.

I have had “Hide Spinner” enabled after the Page Loaded event on the Homepage, as was default.

No Authentication turned on.

It has always worked fine in the SAP AppGyver Preview apps on both the same Android emulator device and my iPhone.

What am I doing wrong?