Android build Error after taking too much time

The android build is taking hours and after that, it is failing with an error.
Status: error
Message: Unknown error, contact support for more details.148196-error.log (1011.8 KB)

I have attached the log file in this topic as well.
I want to build this app for push notification testing

After reading the log file i have found something, please ready below
BUILD FAILED in 3s
Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.

I am using push notification tutorial
Please help me where things are wrong. Thanks

It says its failing in parsing your google-services.json. Did you upload the downloaded google-services.json without modifications?

@Sasu_Makinen thank you for your kind response. Yes i uploaded it with out any modifications.

I’ll take a closer look today or tomorrow morning.

@Sasu_Makinen thank you very much. I will be waiting for your kind response. Thank you again

I see that what you uploaded definitely is not google-services.json, could you try re-uploading it and trying again?

@Sasu_Makinen I am sure I have uploaded google-services.json file but i am going to try again and I will let you know

Yes but I’m afraid the file you uploaded was not the google-services.json file, but something else.

@Sasu_Makinen I have tried again. It took more than a half-hour and after that build was failed with the same error. I am doing all the steps right. This is the link to the recent log file

Not it claims there’s nothing uploaded. Are you sure the upload succeeded? I just tried this thing on my own app and it should work just fine :thinking:

@Sasu_Makinen I checked everything very carefully. Everything was uploaded successfully. This is app id 129740. I can also provide you the google-services.json file. could you please have a look and try to build it.

If you wish you can send the file to me to sasu.makinen@appgyver.com and I can try to configure it into your app.

@Sasu_Makinen Thanks a lot. I have sent you email containing google-services.json file. Please have a look. Thank you very much

I added the file and got a successful build out. Wondering what went wrong with you :thinking:. Which browser are you using?

@Sasu_Makinen I am using Google chrome.

Did you press save & next after adding the file? Not 100% sure if it’s needed but that could be the cause.

For first time i didn’t press save and next but i have pressed these button when i was trying again. I am not sure what is really going wrong.

Anyway hoping to have time to make the buildservice ui & ux better.