Android build Error

Error occurred when I tried to build the Android app:

From the error log file:


FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:processReleaseGoogleServices’.

File google-services.json is missing. The Google Services Plugin cannot function without it.
Searched Location:
│ │

ChildProcess exit with 1 and null
[AndroidBuilder] buildApplication failure!
[SQSListener] domain caught error!
Error: Build failed with errorcode: 1 signal: null
at (/Users/administrator/app-builder/lib/builders/
at Build.emit (events.js:182:13)
at Build.EventEmitter.emit (domain.js:460:23)
at Sbawned.proc.on (/Users/administrator/app-builder/lib/builders/android/models/
at Sbawned.emit (events.js:182:13)
at Sbawned.EventEmitter.emit (domain.js:460:23)
at Sbawned.onExit (/Users/administrator/app-builder/lib/
at ChildProcess.emit (events.js:182:13)
at ChildProcess.EventEmitter.emit (domain.js:460:23)
at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)

Your app is using a feature that’s requiring google-services.json to be added to your build.

Feature for adding this is scheduled for the next release, coming soon.

Ok, but I don’t use any component outside what you provide and my testing app is very simple and doesn’t have any thing related to google service,

1st page to create different “mood” status with image chosen from the user device:

2nd page, using the previous created moods status in a drop down list, to create a list of my current mood with time stamp.

3ed page to show the status generated from the 2nd page with a button for a screen capture, which is useless, since I couldn’t move the captured image to the image directory or share the image with another app. (I really recommend Appgyver to make the captured image go directly to the main image folder of the user like what happens normally when we take a screen capture in our device, and make a function to share the images with different apps like email, facebook etc since currently we can share the text only)

It might be coming from installed flow functions or components. It doesn’t get pruned even though you might not be using it.

These can luckily be uninstalled in the menu.

If you cant find it I can maybe squeeze time today to figure out where it’s coming form if you share your app id.

Uninstalling some flow functions worked for me.

1 Like