Android build failed [keystore]

Hello Appgyver Team, I recently built the IOS version of my app and I had no issues but when I build the android version I get an error. I think the issue might be with the keystore which I generated because it only gave me an option to put keystore password but not the alias password

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:packageRelease’. Failed to read key lincoln from store “/Users/administrator/app-builder/STAGING/dotappgyver/skunkworks/appConfigs/app_293072/certs/release.keystore”: Invalid keystore format

Error: Command failed with exit code 1 (EPERM): ./gradlew assembleRelease -x bundleReleaseJsAndAssets
at makeError (/Users/administrator/app-builder/STAGING/client/node_modules/rnv/node_modules/execa/lib/error.js:58:11)
at handlePromise (/Users/administrator/app-builder/STAGING/client/node_modules/rnv/node_modules/execa/index.js:112:26)
at runMicrotasks ()
at processTicksAndRejections (internal/process/task_queues.js:97:5)

I tried again with a different keystore file and I still get an error

Hi, we just updated the build service documentation and one thing that you could check is your Java version. There have been issues with keystore files generated with JDK version 16, so if your computer has that, you could try to install JDK 15 instead.

I ended up using another Keystore of an app which I published before and it went through. Thanks though, I’ll keep it in mind next time

1 Like