Android failed to initialize Firebase

Hey there, we are kinda struggling with the Android version of our app as the SAP AppGyver preview app is not working (for two months already or so, QR is always “expired” and manual login does not work either).

However, we have tried to test our app with a help of the “App distribution” function on Firebase and we have also tried to install the .apk file directly to the device. In both cases, we are getting an error while trying to log in saying that Firebase is not initialized. We have checked every possibility we could find, but no luck. The app is built just fine, we have set up an Android app in the Firebase and we have tried to re-do everything from the scratch and still getting this error. Any chance someone experienced this and would be able to help us?

Any help with publishing or debugging will be much appreciated! :slight_smile:

Hi @Jaroslav_Krajca, this sounds like a bug both in the Firebase implementation and the SAP AppGyver preview. Could you make a ticket / tickets with your description and app ID in the Tracker, so the issue gets on our quality assurance team’s radar? → Bug Reports | AppGyver