API data fetching with variable in formula not working

Hi, I need some home with fetching data from AirTable.

I am getting null results when I display the data variable after I fetched the record and assign it to the data variable. I can see the data fetched when testing the data resource, but somehow it will not fetch properly.

This worked a few days ago, and I did not make a modification. Can you please help me figure out how to correct the problem?

I am using a filterByFormula query parameter, which is defined as a formula: “lower({email})=lower(’” + appVars.userInputEmail + “’)”. Please note that if I set it to “lower({email})=lower(‘xyz@email.com’)” then the data can be fetched and displayed. I also checked that appVars.userInputEmail is set to “xyz@email.com”. So, obviously I suspect there is a bug with the formula variable substitution. There is an addition of “CONDITION”, “ORDER” and “PAGINATION” fields to be bound, whereas these were not present before.

I tried fetching this data via HTTP Component Get, but the same problem occurs in that I get no records at all.

I also verified that when I start a new project in AppGyver, then this behaviour goes away. I can then use either Get Data Collection component or HTTP Get, either is fine in fetching the data.

Why does we have this type of anomalous behaviour? It sure looks like a bug. Do you have any resolution?

Thanks,

Michael

Hi @Michael_Ho, could you please provide us with your app ID (number in the project’s AppGyver URL) so we can investigate the issue?