API Error 500- You have not created any apps in SAP Builder Composer

When I am trying to open preview portal I receive a API Error 500 message and then the main page shows a label “You have noy created any apps in SAP Build Apps Composer”

Same error on androids SAP Build Apps App

¿Anybody else having this issue?

I dont know if it is related but all day I keep getting this. Unable to work at all. I’ve been deleting and re-creating pages without any success. Any ideas/fixes @Sam_Engstrom @Kirill_Leventcov
P.S. only one instance of the platform is running, i have deleted local cache, cookies, sessions, accessed through chrome, edge, firefox, eventually coming to this error again and again.

1 Like

I tried all the options just like you and in no way could I get it to work. I don’t know if they want us to leave AppGyver.

I am adding all the screens step by step until I get the error. Do you have any updates?

When I log in I can see my projects


I can work on the project, but when I try to launch it next screen is shown

the same behavior exists in the “SAP Build Apps” app

Does anyone else have the same issue?

I believe the previewer no longer supports the old AppGyver Community Edition platform. Have you migrated to the new SAP Build Apps Community Edition? That should require exporting and importing your app to the new platform and reconfiguring the build service.

Thanks Bruno for your answer. I already migrate 2 weeks ago, it was working very well after migration until Dec 2 when this error begins at the same time on web preview and app preview. API Error: 500

If I log into old appgyver everything works fine. got any other idea?

Hi,

Are you still experiencing this? Have you tried waiting a little bit after opening the preview portal?

If you have a lot of apps, it can take a few seconds to load them.

Hello Kirill,

Still the same! I’va just tried again in both, In the web preview the same screen appears saying that I do not have any app and it shows API Error: 500

In android SAP Build Apps app from now on, the applications that I had before migrating are listed and it shows an API Error: 500 message.

Did I do something wrong in the migration and that’s why something mixed up and something wrong happens?

Thanks for your response.

Hi,

The styles on your page look off, and the logo has not loaded for some reason. Are you sure that you don’t have an extension or similar that could be blocking the request?

I’m very sure that I don´t have any extension blocking anything. I’m not sure if the issue begins when I import a GPG file on my current user account.

I have created a new user on a Incognito chrome session and I’ve been working since friday on it, it is working fine.

Is there a way to Logout on chrome so I can Login using the new account?

Thanks for your help.

Try dev tools: f12> go on memory tab and clear site dite, cache, session and everything that lets you clear/refresh. Dayabases, sessions etc. Then login again and see if the error persists.
I have the same issue in my google sheets. I cannot edit app scripts unless logged in in incgonito.

Hi @Kirill_Leventcov Kirill,

I’m experiencing the same issue, wonder if there is a solution on it?

Please use this link to login to the composer: https://agcommunity.design-time.eu10.apps.build.cloud.sap/

that’s the link I’ve been using