APILayer config ends in "The result was not an array. ..." error

Good morning ALL!

I know this is not a new question, but I’ve tried all the available options and I’m still stuck.

I’m trying to get Exchange Rates from an API from APILayer. I have everything configured, but still I get the same error “The result was not an array. Maybe the data you’re looking for is inside one of the response object keys?
I already tried to insert “rates” at the Response key path but the result is the same.
Here’s some screenshots of my configuration and results:

Can somebody help me? I need some help and enlightenment, please.

Thanks in advance.

Do you have screenshots of what happens when you use GET RECORDS (GET) instead of collection?

Hi Mike!

Thank you for your help.
After activating the option, when I get records (instead of collection) I get the result correctly.

What does this mean? Should I use this to create my schema? If I do create the schema with this, I see that the rates have 170 properties, which is exactly the number of currencies provided by this API.

Again, thank you for your help!

When you make a successful request, you can automatically scans the object and sets the properties in your app accordingly, as you can see. It should be fine to just leave it as it is. You should not create your own unless you 100% understand what you’re doing. it sounds like you might only want the rates data? on the config tab where it asks about the Response key path and it’s blank. enter the word rates into that box.and the object will only return the 170 rates object and their properties.