APK generation error

Folks,
I need some help from you. I’m doing a tutorial for a delivery app and I’m at the stage of generating the APK. I installed JDK 15 and it’s showing this error. Below is the error log.
Could you identify what problem is occurring?

Yours sincerely,

Berg

Log:
e[36m[21:56:09.922]e[39m e[36m[DEBUG]e[39m e[36m[temp package] /Users/ec2-user/Library/Caches/Yarn/v6/.tmp/ypx_-42264-xiTR47Vd2xsae[39m
e[36m[21:56:10.071]e[39m e[36m[INFO]e[39m e[36mskip install {e[39m
e[36m rnv: '/Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/node_modules/rnv/package.json’e[39m
e[36m} or maybe u wanna use --ignore-existinge[39m
installed: 155.015ms
e[36m[21:56:10.072]e[39m e[36m[DEBUG]e[39m e[36m[temp package] /Users/ec2-user/Library/Caches/Yarn/v6/.tmp/ypx_-42264-xiTR47Vd2xsae[39m
e[36m[21:56:10.080]e[39m e[36m[DEBUG]e[39m e[36m[CWD] /Users/ec2-user/app-builder/STAGING/client/packages/app-standalonee[39m
e[36m[21:56:10.080]e[39m e[36m[DEBUG]e[39m e[36m[EXEC] /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/node_modules/rnv/bin/index.js [e[39m
e[36m ‘run’, ‘-p’,e[39m
e[36m ‘android’, ‘-c’,e[39m
e[36m ‘app_380635’, ‘-s’,e[39m
e[36m ‘standalone’, ‘–ci’,e[39m
e[36m ‘–mono’, '–no-install’e[39m
e[36m]e[39m
e[90me[39m
e[90m┌──────────────────────────────────────────────────────────────────────────────┐e[39m
e[90m│ │e[39m
e[90m│ e[31m██████╗e[39me[90m ███████╗e[31m███╗ ██╗e[39me[90m █████╗ ████████╗██╗e[31m██╗ ██╗e[39me[90m███████╗ │e[39m
e[90m│ e[31m██╔══██╗e[39me[90m██╔════╝e[31m████╗ ██║e[39me[90m██╔══██╗╚══██╔══╝██║e[31m██║ ██║e[39me[90m██╔════╝ │e[39m
e[90m│ e[31m██████╔╝e[39me[90m█████╗ e[31m██╔██╗ ██║e[39me[90m███████║ ██║ ██║e[31m██║ ██║e[39me[90m█████╗ │e[39m
e[90m│ e[31m██╔══██╗e[39me[90m██╔══╝ e[31m██║╚██╗██║e[39me[90m██╔══██║ ██║ ██║e[31m╚██╗ ██╔╝e[39me[90m██╔══╝ │e[39m
e[90m│ e[31m██║ ██║e[39me[90m███████╗e[31m██║ ╚████║e[39me[90m██║ ██║ ██║ ██║e[31m ╚████╔╝ e[39me[90m███████╗ │e[39m
e[90m│ e[31m╚═╝ ╚═╝e[39me[90m╚══════╝e[31m╚═╝ ╚═══╝e[39me[90m╚═╝ ╚═╝ ╚═╝ ╚═╝e[31m ╚═══╝ e[39me[90m╚══════╝ │e[39m
e[90m│ │e[39m
e[90me[39m│ Version: 0.32.0-rn-version-upgrade.4 │
https://renative.org
:rocket: Firing up!.. │
│ $ rnv run -p android -c app_380635 -s standalone --ci --mono --no-install
│ Start Time: 9/17/2021, 9:56:11 PM │
│ │
└──────────────────────────────────────────────────────────────────────────────┘

[ task ] registerEngine:engine-core[1]
[ task ] configureRuntimeDefaults[1] appId:null
[ task ] checkAndMigrateProject[1]
[ task ] loadPluginTemplates[1]
[ task ] _parsePluginTemplateDependencies[1] scope:root
[ task ] parseRenativeConfigs[1]
[ task ] getWorkspaceDirPath[1]
[ task ] _generatePlatformTemplatePaths[1]
[ task ] checkAndBootstrapIfRequired[1]
[ task ] loadEngines[1]
[ task ] registerEngine:engine-rn[1]
[ task ] findSuitableTask[1]
[ info ] Current Engine: engine-rn
[ task ] registerMissingPlatformEngines[1]
[ task ] initializeTask[1] run
[ task ] => [run]
[ task ] [run] checkIfProjectAndNodeModulesExists[1]
[ hook ] [run] executePipe (‘run:before’)
[ hook ] [run] buildHooks Build hooks not complied. BUILDING…
e[32m[ task ] [run] taskRnvRune[39me[90m[1]e[39m parent:null port:undefined target:undefined hosted:undefined
[ task ] => [run] => [configure]
[ hook ] [configure] executePipe (‘configure:before’)
[ task ] [configure] taskRnvConfigure[1]
[ task ] [configure] configureMetroConfigs[1]
[ task ] => [configure] => [platform configure]
[ hook ] [platform configure] executePipe (‘platform:configure:before’)
[ task ] [platform configure] taskRnvPlatformConfigure[1]
[ task ] => [platform configure] => [project configure]
[ hook ] [project configure] executePipe (‘project:configure:before’)
[ task ] [project configure] taskRnvProjectConfigure[1]
[ info ] [project configure] Creating folder ./platformBuilds …DONE
[ task ] [project configure] checkAndMigrateProject[2]
[ task ] [project configure] loadPluginTemplates[2]
[ task ] [project configure] _parsePluginTemplateDependencies[2] scope:root
[ task ] [project configure] _parsePluginTemplateDependencies[3] scope:ag
[ task ] [project configure] parseRenativeConfigs[2]
[ task ] [project configure] getWorkspaceDirPath[2]
[ task ] [project configure] _generatePlatformTemplatePaths[2]
[ task ] => [project configure] => [workspace configure]
[ task ] [workspace configure] taskRnvWorkspaceConfigure[1]
[ warn ] [workspace configure] You’re missing defaultTargets in your config /Users/ec2-user/app-builder/STAGING/dotappgyver/renative.json. Let’s add them!
[ task ] <= [project configure] <= workspace configure
[ task ] [project configure] checkIfTemplateConfigured[1]
[ task ] => [project configure] => [install]
[ hook ] [install] executePipe (‘install:before’)
[ task ] [install] taskRnvInstall[1] requiresInstall:false:true
[ hook ] [install] executePipe (‘install:after’)
[ task ] <= [project configure] <= install
[ task ] [project configure] checkCrypto[1]
[ task ] [project configure] configureRuntimeDefaults[2] appId:null
[ task ] [project configure] applyTemplate[1] renative-template-hello-world=>undefined
[ task ] [project configure] _applyTemplate[1] current:renative-template-hello-world selected:undefined
[ task ] [project configure] configureRuntimeDefaults[3] appId:null
[ task ] => [project configure] => [install]
[ hook ] [install] executePipe (‘install:before’)
[ task ] [install] taskRnvInstall[2] requiresInstall:false:true
[ hook ] [install] executePipe (‘install:after’)
[ task ] <= [project configure] <= install
[ task ] => [project configure] => [app configure]
[ hook ] [app configure] executePipe (‘app:configure:before’)
[ task ] [app configure] taskRnvAppConfigure[1]
[ task ] [app configure] listAppConfigsFoldersSync[1] ignoreHiddenConfigs:true
[ task ] [app configure] listAppConfigsFoldersSync[2] ignoreHiddenConfigs:true
[ task ] [app configure] matchAppConfigID[1] appId:app_380635
[ task ] [app configure] _setAppId[1] appId:app_380635 runtime.appId:null _meta.appId:undefined
[ task ] [app configure] loadPluginTemplates[3]
[ task ] [app configure] _parsePluginTemplateDependencies[4] scope:root
[ task ] [app configure] _parsePluginTemplateDependencies[5] scope:ag
[ task ] [app configure] parseRenativeConfigs[3]
[ task ] [app configure] generateBuildConfig[1] size:175.01 KB
[ task ] [app configure] getWorkspaceDirPath[3]
[ task ] [app configure] generateBuildConfig[2] size:175.42 KB
[ task ] [app configure] generateBuildConfig[3] size:175.42 KB
[ task ] [app configure] generateBuildConfig[4] size:175.42 KB
[ task ] [app configure] _generatePlatformTemplatePaths[3]
[ task ] [app configure] generateBuildConfig[5] size:198.27 KB
[ task ] [app configure] generateBuildConfig[6] size:198.74 KB
[ task ] [app configure] getWorkspaceDirPath[4]
[ task ] [app configure] generateBuildConfig[7] size:198.74 KB
[ task ] [app configure] generateLocalConfig[1] resetAppId:false
[ task ] [app configure] generateBuildConfig[8] size:198.78 KB
[ info ] [app configure] Current App Config: app_380635
[ hook ] [app configure] executePipe (‘app:configure:after’)
[ task ] <= [project configure] <= app configure
[ task ] [project configure] versionCheck[1]
[ task ] [project configure] versionCheck:rnvRunner:0.32.0-rn-version-upgrade.4,rnvProject:0.32.0-rn-version-upgrade.4[1]
[ task ] [project configure] configureEngines[1]
[ task ] [project configure] resolvePluginDependants[1]
[ task ] [project configure] configurePlugins[1]
[ info ] [project configure] RNV Detected plugin dependency conflict. RESOLVING…

  • @react-navigation/stack@5.9.2 <=
  • @react-navigation .npm sub dependencies:
    |- @react-navigation/stack@5.1.1
    [ task ] [project configure] configureRuntimeDefaults[4] appId:app_380635
    [ task ] [project configure] copyRuntimeAssets[1]
    [ task ] [project configure] parseFonts[1]
    [ task ] [project configure] configureTemplateFiles[1]
    [ task ] [project configure] checkAndCreateGitignore[1]
    [ task ] [project configure] checkAndCreateBabelConfig[1]
    [ task ] [project configure] generateRuntimeConfig[1]
    [ task ] [project configure] overrideTemplatePlugins[1]
    [ task ] [project configure] parsePlugins[1]
    [ warn ] [project configure] No Match found in /Users/ec2-user/app-builder/STAGING/client/node_modules/react-native/ReactCommon/turbomodule/core/platform/ios/RCTTurboModuleManager.mm for expression: RCTBridgeModuleNameForClass(module)).
    Consider update or removal of ./node_modules/@appgyver/orchestra-plugins/pluginTemplates/react-native/overrides@0.62.3.json
    [ hook ] [project configure] executePipe (‘project:configure:after’)
    [ task ] <= [platform configure] <= project configure
    [ task ] [platform configure] isPlatformSupported[1]
    [ task ] [platform configure] checkAndConfigureSdks[1]
    [ task ] [platform configure] checkAndConfigureAndroidSdks[1] (/Users/ec2-user/Library/Android/sdk)
    [ task ] [platform configure] isBuildSchemeSupported[1]
    [ info ] [platform configure] Current Build Scheme: standalone
    [ task ] [platform configure] checkSdk[1]
    [ task ] [platform configure] _isSdkInstalled[1]
    [ task ] [platform configure] configureRuntimeDefaults[5] appId:app_380635
    [ task ] => [platform configure] => [install]
    [ hook ] [install] executePipe (‘install:before’)
    [ task ] [install] taskRnvInstall[3] requiresInstall:false:true
    [ hook ] [install] executePipe (‘install:after’)
    [ task ] <= [platform configure] <= install
    [ task ] [platform configure] [1] taskRnvPlatformConfigure hasBuildFolderPresent:true
    [ task ] [platform configure] createPlatformBuild[1]
    [ task ] [platform configure] injectPlatformDependencies[1]
    [ hook ] [platform configure] executePipe (‘platform:configure:after’)
    [ hook ] [platform configure] buildHook.setupWebRTC (EXECUTING)
    [ task ] <= [configure] <= platform configure
    [ task ] [configure] configureEntryPoint[1]
    [ task ] [configure] configureGradleProject[1]
    [ task ] [configure] copyAssetsFolder[1]
    [ task ] [configure] configureAndroidProperties[1]
    [ task ] [configure] configureProject[1]
    [ task ] [configure] parsePlugins[1]
    [ task ] [configure] parseFonts[1]
    [ task ] [configure] parseAppBuildGradleSync[1]
    [ warn ] [configure] DEPRECATED structure in /Users/ec2-user/app-builder/STAGING/dotappgyver/@appgyver/orchestra-app-standalone/appConfigs/app_380635/renative.private.json.
    Your android object needs to be located under platforms object.
    [ task ] [configure] parseGradleWrapperSync[1]
    [ warn ] [configure] You are missing backgroundColor in your renative config. will use default #FFFFFF instead
    [ task ] [configure] parseAndroidManifestSync[1]
    [ task ] [configure] parsePlugins[2]
    [ task ] [configure] _checkSigningCerts[1]
    [ task ] [configure] copyBuildsFolder[1]
    [ task ] [configure] copyTemplatePluginsSync[1] (./platformBuilds/app_380635_android)
    [ task ] [configure] parsePlugins[3]
    [ task ] [configure] jetifyIfRequired[1]
    [ hook ] [configure] executePipe (‘configure:after’)
    [ hook ] [configure] buildHook.generatePlugins (EXECUTING)
    [ hook ] [configure] buildHook.updateDolan (EXECUTING)
    [ hook ] [configure] buildHook.downloadImages (EXECUTING)
    [ hook ] [configure] buildHook.setIsDev (EXECUTING)
    [ hook ] [configure] buildHook.generateDolanParserConfig (EXECUTING)
    [ hook ] [configure] buildHook.setupDynamicWebNextJSFonts (EXECUTING)
    [ hook ] [configure] buildHook.preparePublicRoutesMaps (EXECUTING)
    [ hook ] [configure] buildHook.setupVercelDeploymentRegions (EXECUTING)
    [ hook ] [configure] buildHook.setRuntimeVersion (EXECUTING)
    [ hook ] [configure] generatePlugins
    [ hook ] [configure] _generatePlugins
    [ task ] [configure] parsePlugins[4]
    [ hook ] [configure] updateDolan
    [ hook ] [configure] updateDolan releaseTargetId:undefined platform:android scheme:undefined
    DOLAN is non-releaseTarget mode: https://dolan-api.appgyver.com/dolan_api/v2/apps/380635/dolan.json?flavour=dev&hash=4325b59ec4319d73aa5b685af63a27637ccc4164c70304ad725fb7f0359e38b1
    readObjectSync:/Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformAssets/dolan_master.json

DOLAN PARSER REPORT

TOTAL PAGES: e[33m3e[39m
TOTAL COMPONENTS: e[33m18e[39m
TOTAL BINDINGS: e[33m10e[39m
TOTAL BIND DEPENDECIES: e[33m40e[39m
NORMALIZED BINDINGS: e[33m19e[39m
REMOVED EXPRESSIONS: e[33m0e[39m
INVALID EXPRESSIONS: e[33m0e[39m
FIXED EXPRESSIONS: e[33m0e[39m
TOTAL EXPRESSIONS: e[33m0e[39m
CONFLICTING COMPONENT IDS e[33m0e[39m
TOTAL FLOWS: e[33m85e[39m

[ hook ] [configure] DOWNLOAD IMAGES
Matched image https://s3.amazonaws.com/appgyver.assets/composer3/images/image_placeholder.png
downloadImages:URLS: []
cleanFolder /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformAssets/runtime/_temp
NO IMAGES to download
[ task ] <= [run] <= configure
[ task ] [run] startBundlerIfRequired[1]
[ task ] [run] packageAndroid[1]
[ info ] [run] ANDROID PACKAGE STARTING…
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 30s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 60s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 90s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 120s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 150s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 180s
Executing: react-native bundle --platform android --dev false --assets-dest /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/res --entry-file index.client.android.js --bundle-output /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/platformBuilds/app_380635_android/app/src/main/assets/index.android.bundle --config=metro.config.js - 210s
[ info ] [run] ANDROID PACKAGE FINISHED
[ task ] [run] runAndroid[1] target:undefined default:undefined
[ task ] [run] _runGradleApp[1]
┌──────────────────────────────────────────────────────────────────────────────┐
:rocket: SUMMARY | 9/17/2021, 9:59:50 PM │
│ $ rnv run -p android -c app_380635 -s standalone --ci --mono --no-install │
├──────────────────────────────────────────────────────────────────────────────┤
│ ReNative Version: 0.32.0-rn-version-upgrade.4 │
│ Project Name ($package.name): @appgyver/orchestra-app-standalone │
│ Project Version ($package.version): 2.12.2 │
│ Workspace ($.workspaceID): buildservice │
│ Platform (-p): android │
│ Engine ($.platforms.android.engine): engine-rn │
│ App Config (-c): app_380635 │
│ Build Scheme (-s): standalone │
│ Bundle assets ($.platforms.android.bundleAssets): true │
│ Target (-t): Nexus_5X_API_26 │
│ Supported Platforms: android │
│ Env Info: darwin | x64 | node v16.2.0 │
│ Executed Time: 0h:3m:38s:424ms │
│ │
│ [ warn ] [workspace configure] You’re missing defaultTargets in your config /Users/ec2-user/app-builder/STAGING/dotappgyver/renative.json. Let’s add them!
│ [ warn ] [project configure] No Match found in /Users/ec2-user/app-builder/STAGING/client/node_modules/react-native/ReactCommon/turbomodule/core/platform/ios/RCTTurboModuleManager.mm for expression: RCTBridgeModuleNameForClass(module)).
Consider update or removal of ./node_modules/@appgyver/orchestra-plugins/pluginTemplates/react-native/overrides@0.62.3.json
│ [ warn ] [configure] DEPRECATED structure in /Users/ec2-user/app-builder/STAGING/dotappgyver/@appgyver/orchestra-app-standalone/appConfigs/app_380635/renative.private.json.
Your android object needs to be located under platforms object.
│ [ warn ] [configure] You are missing backgroundColor in your renative config. will use default #FFFFFF instead
│ [ error ] [run] COMMAND:

./gradlew bundleRelease -x bundleReleaseJsAndAssets

FAILED with ERROR:

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:processReleaseGoogleServices’.

No matching client found for package name ‘br.com.delivery.app’

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 3s

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See Command-Line Interface
131 actionable tasks: 131 executed

Command failed with exit code 1 (EPERM): ./gradlew bundleRelease -x bundleReleaseJsAndAssets

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:processReleaseGoogleServices’.

No matching client found for package name ‘br.com.delivery.app’

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 3s

Error: Command failed with exit code 1 (EPERM): ./gradlew bundleRelease -x bundleReleaseJsAndAssets
at makeError (/Users/ec2-user/app-builder/STAGING/client/node_modules/rnv/node_modules/execa/lib/error.js:58:11)
at handlePromise (/Users/ec2-user/app-builder/STAGING/client/node_modules/rnv/node_modules/execa/index.js:112:26)
at processTicksAndRejections (node:internal/process/task_queues:96:5)

│ │
│ Project location: │
│ ./platformBuilds/app_380635_android │
└──────────────────────────────────────────────────────────────────────────────┘
exec: 3:40.231 (m:ss.mmm)
remove temp package: 1.936ms
ypx: 3:40.397 (m:ss.mmm)

Hi @Berg_Souza! The relevant error here is

No matching client found for package name ‘br.com.delivery.app’

Have you checked that your package name br.com.delivery.app is the same in your google-services.json file and in the “Package identifier” field in the build configuration?

Hi!
I had the same problem. but I had no google-services…
My problem came at the same line and in the end it says I am using a deprecated gradle comparing with the 6.0 the aplication is using. Could I do something with it?
I explained it in a build issue topic yesterday too!!
I don’t know to get over it!!
It happen after I build at the same day with a successfull built.