App brought to foreground via URL no longer passing parameters - Our auth broken

We have been accessing Sign in with Google and Sign in with Apple thanks to the ‘App brought to foreground via URL’ event which passed us the parameters.

We were trying to address some issues with the login process and see that now we don’t appear to have any way to access the parameters anymore.


This breaks our auth process. Is there another way that we should be accessing the parameters?

App #98690
Page: Login

Hi,

Thank you for your report! There was a bug in our previous release.

We have just released a Hotfix #139A update that should fix this issue for you! Just refresh the browser to ensure that the fixes take effect. Hopefully it now works for you? Please let us know if you still encounter related issues!

Here’s the related changelog: https://docs.appgyver.com/changelog

Thanks, your report helped us to identify and fix the issue easily!

1 Like

Oh yay! Trying it now. I’ll report back.

It’s not working in my first round of testing, but that could be an issue on our part. My developer is at his day job right now and auth is his thing, but I’ll report back once he has had a chance to verify that our portion is all intact. Thank you @Kimmo!

The event outputs are showing up now! Thank you so much @Kimmo!

We had a new strange bug arise in the process; maybe you can give me an idea of whether this could be related.

The Sign in with Google process works great on Android. However, when I try it on the iPhone, it says “Safari cannot open the page because the address is invalid.”

I diff checked the url from Android and the url from iPhone, and they’re identical. I tried manually pasting the url into Safari on the iPhone and got the same result.

Hi! Not super sure, but after reading this I think you might need to try this on standalone with an URL scheme defined in the build settings for it to work correctly, or direct it to appgyver:// (I think?) while using the Preview app.

1 Like

Figured it out. Was totally an error on our part. Thanks!

1 Like