Appgyver app for Android doesnt work

I just installed an update to the Android Appgyver app from Playstore and now none of my projects will appear. It just shows a never ending spinner. And i have no way to reinstall the older version. Is there a fix for this coming?

1 Like

I have the same issue on an iPhone.

I have found a different app call Appgyver Legend in the Iphone App Store. My app works on that. Not sure if you have the same app in Google Play store. Worth having a look.

1 Like

I’m having some difficulties, too. @Harri_Sarsa Here are some specifics. Hopefully they hold some clues for you:

  1. Buttons that don’t have an outline in the Composer are showing up with an outline in the previewer app:

  2. Before, the debugger wasn’t showing me any data. Data is showing up now (yay!). I notice that the flow functions are missing their names. The event triggers “Page Mounted” and “Componenet tap” show up named, but that’s it. I even re-saved after giving custom names to a few nodes, but those don’t show up, either. That isn’t a huge problem for me now, but I know when I get into deep debugging, the process will get more tedious when I have to expand each one to figure out what it is.

  3. Sometimes a really long load time when I opened my app in the previewer. Long enough for me to think it stalled out and start trying to figure out how to replicate it. It did eventually load.

  4. New flow functions not always showing up in debugger: I click a button and get the expected result in the app, but the flow function chart doesn’t always update.

  5. Won’t load new pages when I click the button to do so. I can see that the other flow functions are happening (updating variables, etc.)–even the ones following the page open node (so it thinks it successfully opened the page)–but it doesn’t send me to the next page. This is the most urgent of the bugs.

  6. Debugger didn’t clear data when I backed out of the app (to the Apps page of the previewer).
    Here it shows I’m connected and populated with data, but you can see I’m fully out of my app:



    When I tried to refresh the debugger, it gave me this:

    Another time when the debugger didn’t reset when I backed out, I closed the debugger window and re-opened it. Now, in the app, I can’t toggle “Connect to Debugger” off (the re-opened debugger shows disconnected).

  7. I tried connecting to the legacy debugger and hit all the same stuff (which makes no sense…). So I guess the issue is in the app? Looks like I have version 2.4.17 on Android (last updated Dec 8th)

  8. I downloaded the backward-compatible app (AppGyver Legend). It works great with the legacy debugger. With the new debugger, it connects but does not show data (which sometimes happened with the new app, too.)

So Legend app + legacy debugger will get me through while you guys refine the new versions. (I’m still excited for them, btw.) Thanks for keeping those available!

Hey @JOHN_WORSHAM and @Dan,

have you updated your flow functions? If you haven’t you should update all of your flows and view components to the latest versions.
There is a known issue with the old version of the hide spinner flow, and it should be fixed once the flow is updated.

And yes the AppGyver Legend -app is official app with the old runtime just for this reason, it is available in the Google Play store and Apple App store.

There are still few regression that are known and certainly some that are unknown, and the goal is to have all apps look the same even if it was built for the old runtime. So if there are some discrepancies between the runtimes, please let us know so we can fix them!

Please have a read about the change log, thank you! :slight_smile:

Hey @Erin_Wagner, first of all thank you for this!

You should update all of the available updates, since there might be updates that are required by the new runtime.

The first issue might be caused by the sub-properties of the Width, if you look under the Width property(click the small arrow on the left of Width), do you have properties set there? Or are the top, left, bottom and right properties all 0?
If they are empty / all zeros, could you give me the app ID(can be found from the URL applications/<ID>/pages) so I can take a closer look?

3rd issue, when did this happen? Does this still occure, just wanna know if this is something with the app or if this was just slow server.

5th issue, could you test again after updating the flow functions?

For all the debugger issues, I will take a closer look at them and try to reproduce all of them so that they can be fixed.

Thanks again! :slight_smile:

Thank you for the Legend app. It worked.

Thank you @Kristian_Gerkman,

I have updated all the flow functions but I still can’t get past the spinner when I open the app. :thinking:

Not sure why. Any idea? It still works in Appgyver a legend.

Can you check if it works now? There was a small disturbance open apps in preview right around the time you posted this.

It still doesnt load.

It works now! :slight_smile: :slight_smile: :slight_smile:

Okay, seems like there are still some issues with that, since it doesn’t load all the time.

My is still not loading. :frowning_face:

Can you confirm that you are testing with the latest 2.20 from the App Stores?

@Dan can you try if you can navigate back from the view of the spinner? I was able to reproduce this one one device, so that it automatically went to spinner when the preview app opened and stayed spinning. However, I was able to navigate back to the main app listing, and after that everything works. We are investigating what may be causing this but just wanted to check if this could help your situation.

@Erin_Wagner it seems from the screenshot like there are 11 components in the component market (red circle with 11 items). Can you check if the button component is to be updated? This could be the issue with the border. We will investigate the debugging issue you’re having if we can reproduce it.

Hi @Marko_Lehtimaki,

I have the latest app installed from the App Store. It was when I updated yesterday it stopped working and stayed on the spinning wheel.

I don’t get an option to back. All I get is the spinning wheel.
I took a picture of it, not that there is anything to see so not sure if it helps your investigation.

Thank you for trying to fix it.

Dan

@Dan could you please try to swipe to right, starting from the left edge of the screen? i.e. the “go back” swipe of iOS? We were able to find the reason this happened to some users, and it’s on its way to the app stores, but in the meanwhile, please try this as I believe it could help.

Hi @Marko_Lehtimaki,

I have just tried to do that. Sadly it doesn’t change the problem. I get back to the Apps screen but the same happens when I go back into the app. :slightly_frowning_face:

@Dan we are tracking down an issue that could cause this — can you share your app ID so we can make sure the fix (should be deployed tomorrow) works? In the meantime, you can use preview-legend.appgyver.com and AppGyver Legend from App Store/Google Play to utilize the old runtime.

Thanks @Harri_Sarsa for your reply. App working fine on the AppGyver Legend :+1:

My App Id is 156736, hope you can find a fix. Thank you for all the work you are doing.

Dan