AppGyver preview adding characters that do not exist in a query parameter when making a request

Im having a issue or a bug that is very strange, I have an api that is connected with appgyver. So far so good but today something very strange is happening, when making a request the query parameter that should be sent in the request is not actually the one that the server is receiving. for some reason the appgyver add a string"20" in front of a id so when the server reveive the request the id is wrong. The no sense part is that the request in the debug is actually right. Idk where in the request that this str “20” is added to the parameter. I have 3 images, the first one is the request data in the appgyver in the debugger, so is the exact value that should be sent, and it shows correct. then I have the image of the actual request in the chrome console, we can se that a “20” is added in the id parameter. Finally what my api receive, Again with that wrong string. obviously my api cant find this on database since this id does not exist. If I go on postman and make the same request without the “20” in front of the id it works fine. So the question is where and why this parameter gets changed.

That is a url encoded “space”, check out here:

Also, this means that there is an empty space before your id in the request.

Do you use a formula to set the id? If yes, then wrap your formula into a TRIM_WHITESPACE(yourformula here) and that should solve it. Or just check if you have an empty space before the id anywhere…

In my defense, was 2:30 am and didn’t see the space in the debugger string. It’s was so obvious, I should have seen. I’ll just see where this random space came from. Thank you.

Hi @Mihaly_Toth,

I had a problem similar to this case, so I made a GET API call, I tested it on the configurator data and it ran normally without any problems, but when I ran the call through the app preview, the first time there was no problem, but after I refreshed, an error occurred. After I inspected it through the browser console, it turned out that there was an additional “/” character behind the api endpoint that shouldn’t be there, I’ve tried toggling on/off ENCODE in the config data but it has absolutely no effect. please help.