AppGyver with Sharepoint

So I have painstakingly linked my sharepoint list to appgyver, I know it reads the data because I have successfully gotten the schema and it reflects on the builder. However, when I preview the app on my phone, the list doesn’t show at all. What am I doing wrong? :frowning:

Hi there!

Does it show the data in the test tab of the method configuration? The schema is cached when you run the test and can thus become out of sync with the actual data.

Hi, on the GET RECORD it shows up OK:
image
and test is ok:

but, on GET COLLECTION, I seem to have an error. Maybe this is it?

thanks so much for your help…

Pretty much what the error says - you’re not getting an array back, which is what Get Collection expects esp. if it were to receive more than 1 object.

Yes, understood on this. This is what I’m stuck with… I dunno how to “tell” AppGyver to read this as an array… because my Sharepoint data JSON is an array to begin with… I’ve tried different accept params, but still no luck…

What does your Get Collection configuration look like that’s different from Get Record?

Im thinking you need to put “value” in your Response Key path for Get Collection

2 Likes

Get Collection Config looks like this:

Get Record looks like this:
image

so the only difference is the ({ID})

From what I can tell - pointing appgyver to the specific item in the list returns the correct data
however, if I point appgyver to the list per se (Get Collection) it doesn’t recognize it as a list.

Looking at the test output of Get Collection:

I think that the culprit there is the “value”: [] statement which negates the array format. But this always gets returned no matter the parameters…

OH MY GOD. THANK YOU!!! THIS WORKED!! THANK YOU SOO MUCH!

This solved it! :slight_smile:

2 Likes

Hi Rayner,

I am also trying to make a data connection with SharePoint list but I am getting “Non-Json error body.status:403”. The reason is SharePoint apiurl is always in xml. Could you please help me how you dealt with this issue as you are successful in making connection. That will be very helpful.

Thank you

Your response has to be JSON format to work. There isnt a way to read XML