Apply App Store does not accept Appgyver Apps anymore


I just tried to upload a new iOS build with v2 and got the following message from Apple Store Connect while trying to upload:
ITMS-90809: Deprecated API Usage - New apps that use UIWebView are no longer accepted. Instead, use WKWebView for improved security and reliability. Learn more (

Does this mean AppGyver is not working anymore with iOS devices?

Thanks and best,

Thanks for the report, looking into this now! What is your app ID so we can check the build settings?

This should be fixed with 2.4.25, available from Build Service now!

1 Like

Hey Harri,

thanks, but I dont see 2.4.25 in the build service, its still 2.4.24 for iOS…


Sorry, forgot to flip one final switch. It’s visible there now!

Thank you, upload worked now (unfortunately it is still 10x larger).
Unfortunately, the app stops working after 2 clicks in test flight.
It works in the preview app. Is the preview app already using this latest runtime version?

The update shouldn’t have affected that – is there a specific view component being rendered or flow function being run when the issue happens? It could be there’s a missing plugin dependency somewhere.

We’re gearing support down for Christmas unfortunately, but @Kristian_Gerkman can investigate this on Monday. Sorry for the struggle, trying our best to get this fixed ASAP!

Thank you!
I could actually solve the freezing piece, it looks like the internal storage had an issue during the upgrade. When I removed the app from the device and installed it again, it worked.
So the remaining issue is the too large build size.
@Kristian_Gerkman, it would be awesome if you could have a look in Monday.
After the build issues had been fixed beginning of this week, the iOS build is 10x larger than before. One issue may be be that you have the libSwift* twice in, once in Payload/Frameworks, once under SwiftSupport. These libs are now also added to the 1.5.X builds and where not there before…


Hey @Johannes,
I’m not sure about the 10x part, but definitely larger file!

Do you actually mean 10x the size of the original, or 10MB larger? I tested with empty app, and 2.4.15 is 6MB and 2.4.25 is 16MB - also tested with another app that was not empty and saw similar results. So I’m not sure how the app could be 10x larger.

My IPA file went from 15 MB to 126MB without me adding anything, so its nearly 10x.
Would be great if you have a look!
(App 168959)

My IPA file went from 15 MB to 126MB without me adding anything, so its nearly 10x.

Sorry about the delayed answer!

The issue is with some included plugin(s), and it is a runtime issue, so for now all we can do is wait until the runtime developers come back from their holidays (after New Year). :pensive:

No worries, thanks! And happy new year! :slight_smile:

1 Like