Audio Stream not Playing in Appgyver Preview on Iphone

Hi my question is straightforward. I built a live audio stream app and have published it on Google play for android and the audio stream works fine in the Appgyver Preview app for android as well as the standalone app itself (as I pre-tested it obviously) Now I want to release it on the Apple store but need to test it works okay on the Appgyver Preview app for iPhone but the audio stream will not play on there. Am I missing something? Is it maybe because of permissions for iPhone and it’s a preview and not the actual standalone app itself? It works fine on android in the preview and as standalone so why not in the iPhone preview app? Please help!!

1 Like

I’ve posted about this recently also. I’ve tried every combination of flows I can think of and iOS Preview App just doesn’t do it.

I even added a custom JS component and all platforms except iOS play fine.

We’ll just have to wait for one of the Devs on here to respond I guess.

FYI; I’ve posted it as a bug here. Please upvote.

Hi thank you for your reply. At least now I know this is an issue and not just something I did. Do you know if it’s just on the preview? What I mean is everything else looks fine on the preview so I’m ready to publish as long as I know the audio will play on the actual app itself. I just obviously don’t want to publish it in order to find it doesn’t work on the app itself.

Screen Shot 2021-06-22 at 7.11.01 pm

Firstly, could I ask you to upvote the bug I posted. Hopefully it will gain the attention of a dev on here.

There appears to be a couple of others facing the same issue reading other posts on here. Surprised none of the Devs or other people frequenting the forum haven’t posted as of yet.

I’m not sure if it’s just the Preview app. Its a fair few hoops to go through the publish to App Store to learn if it is just the Preview app or not.

What I do know is the multiple different flows I tried, including a custom JS script worked on web browsers and Android Preview app, but not once could I get it to work on iOS.

Hi. Again thanks for your reply. You are right, it is quite a few steps to get published just to find it doesn’t work on the actual app. I guess something will become clear soon or at least I hope it does. I have tried signing up to that site in order to up vote your topic about 5 or 6 times but I just keep getting a server error. I will keep trying throughout the day.

1 Like

Here’s a link to the bugs homepage.

This has thrown up a new issue for me. I cannot log in to up-vote it. Every time i try i get that same server error message whether on my laptop or phone and whether in normal browse mode or incognito mode it’s the same outcome. I googled the problem and all i could find was someone else who had the same problem with appgyer too. I am perplexed. Here is that thread.

Hey. Did you manage to resolve the audio playing issue? If so, what did you do to workaround the issue?

No I didn’t. I have had to basically shelve this idea for now as I am so busy. I was hoping that somebody could have shed some light on this problem by now.

Hi. I just started with Appgyver and been having this problem too. Has anyone manage to resolve this issue?