Binding app variable to airtable data problem

Hello all,

I am facing a problem when I try to bind an app variable to the data variable (I am using airtable as a data variable).

Basically, the only way I found to create a new record on the airtable was through input fields as the tutorials teaches, but I would like to create a new record from an app variable.

I have already read the solution proposed by @Oli_Clark in the topic: Issues Passing Data To Airtable through the POST request, and it seems exactly what I want, but I get no new records when I do what he explained.

I have an app variable that gets its value from the choice of two different adresses as below. After the user clicks on one checkbox, the app variable is set with a text value (I already checked if the app variable is “holding” the value).

After setting the app variable, I want to create a new airtable data record with the value from the app variable, so I used the node “create record” and set the “record properties” as custom object.

I set as below in the record properties: for the field “EnderecoEntrega”, I want it to be recorded with the same value from the app variable “Endere”.

I really don’t know if I am doing something wrong.

P.S.: I already set the data variable type to “New data record”

ID: 98096

Can you start with showing the error message you get from Create record? A good place to bind it is Dialog message of Alert in Optional inputs section. Maybe that will give you more info, cause to me it seems that the configurations are done correctly (though I’m not familiar with Airtable)

image

Hello,

@Tomi_Laakso, thank you for the prompt answer.

The error msg I get is attached below, but I don’t know what it means.

Error msg

Okay, are you sure that you have configured the data resource correctly? I’d first try to make a Create record request with just static data and see if it works. Just to see if end-point, token, etc work and e.g. if Airtable requires more fields to have value than just the one.

(You can also run the app and request in web preview with console open to possibly see more details about the request.)

I have no ideia why, but after I added a “set data variable” with its data as a “custom object” before the node “create record”, it worked.

That sounds quite odd… But good that it works now for you. We’ll keep an eye on related issues and go for a fix when we can repro the issue.