Bold text won't appear in the build versions and Composer Preview Bug

This happens both on iOS and Android.
Once I run the APK/TestFlight, the bold text that appeared in the SAP Preview App and in Composer Pro disappear.
SAP App


iOS TestFlight version

Currently I’m using runtime 3.3.5 (because the app logos were wrong and the size is a lot bigger in newer versions) but the bug also appears in the latest 3.4.5

I’ve also got a different bug in composer pro which renders the page preview wrong:
image

Hi! What font and font weight are you using? I’ve seen weird behaviour with font weight when the specific font weight has not been supported, so check that if you use 700 as font weight if this still happens?

Setting it to 700 fixed it. However I noticed that I had it set at 600 and that isn’t even a selectable option.

I am using:
Monospace font $fontFamily_monospace Space Mono
Primary font $fontFamily_primary Poppins
Secondary font $fontFamily_secondary Poppins

which are the default fonts

How I fixed it:
Went to “Theme” (top of the dashboard) → “Theme Variables” → “Font Family” → “Font Family Variables”.
There I changed all fonts (Monospace/Primary/Secondary font) to “72” → save → change back to the original font (Or whichever you want)