Bug? Checkbox does not change initial colour

I am really not so sure if I am reporting a bug of any sort… And to be fair I am always able to confuse "issue"s with "bug"s with "build"s and the loop goes on… So I am not sure if I should report it or not?

None the less I would like to best share a problem I ran into and what I did to solve it…

You see: I can’t seem to have the “Checkbox” icons colours work

No matter what colour I tend to set either of the colours associated with it: the inactive one ALWAYS gives me the same old: “#cbcbcb:confused:

I found a sort of work around for it by simply making the text around it match the so called “”#cbcbcb"…


But as much as it worked with the basic formatted version: IT really failed to go par with the actually intended theme.

Thus I just replaced it with a rather annoyingly long formula binding four images per each to being in “theme” or not (and if so if they are to show or hide the password).

In the end: these eyes matched the concept much better as they were literally custom built. But the time loss and so forth: I really weigh it’s worth.
And I would not want to keep running into this if avoidable.

Is there something I am missing?

Or is this one f the glitches that I should be reportın… I honestly couldn’t be too sure.

Thanks for reporting this! The inactive color not working correctly is definitely a bug and I was able to confirm this and report this onwards :slight_smile:


That’s great to hear!

Sadly I assume it would be best momentarily I just consider it how I have had resolved my problem. Since it may take long to fix… And it would be wrong/pointless harassing you to hurry up on it :smiley:
You guys have already done outstanding service for the community… Anything now onwards is just building up onto what already is an unbelievable service. Thank you Mevi for your time :love_you_gesture: .

Can I please ask you to check on two more things when ever you have the time? :pray:t2:

  1. Like when I fill a container, scroll view or what not; with a tile-able texture of my own making… On android/iOS I tend to get it to fully repeat as per my settings. But when I change the orientation of the device to landscape or portrait (Depending on the initial orientation) the repeated texture keeps to the initial layout and the new estate on screen gives not the texture but the primary background colour of my theme.

Please note that I do have Stretch to the view-port height & Disable scrolling checked… AND that it works rather perfectly on app preview portal for the web.

  1. My other problem is possibly local but what I keep getting is that though dismissing the initial view from my app preview rather successfully works on mobile devices: I can never get beyond logging in with the app preview portal for web.

A possible culprit is the Initialize Firebase flow or the Get current user (firebase Auth) flow since all was working well until I set up a “register an account” option where I sent an HTTP “POST” request. Never worked since then. :thinking:
I haven’t troubleshooted this in any way from too much work elsewhere keeping me TOO busy… But even if such… when you have the time: You may want to check into that.

Thank you and your team for everything! :hugs:

EDIT / PS: I forgot to mention that I have a personal way around it since I have two formats of the app… One “textured” and the other: not. So if textured is selected I disable orientation.
Sadly this is the best I was able to come up with for the meanwhile :disappointed:

1 Like

I’ll answer quickly as I’m not able to look into these more deeply right now –

  1. Sounds like a bug that should be reproducable, so I’ll check it out and file a bug report if I am able to reproduce it.
  2. Shoulddddd not be a bug, but I’d have to try to reproduce this, and naturally this one is… a lot more work to try to reproduce, so I would prefer not to :sweat_smile: Please check what error(s) if any you get into your browser developer console, find out where exactly the flow gets stuck and show me with screenshots etc. If we can’t figure out what’s going on, if it’s a bug or not, I’ll try to reproduce the issue, but let’s try to debug your situation first.
1 Like

Hello and thanks again Mevi!

I am WAY over my head and I pretty much lack ability to get back here to even thank you in time :cold_sweat:
My sincere apologies…

Sadly it is pretty much reproducible… at least in my side of the world :disappointed:

Sadly I can not share the other app screens but of the old project this happened to in first… Here you go (To give you a visual idea):

This is what the tile is supposed to look like… And looks darn well in this way. So such I have disabled orientation adopting.

Because when in landscape I get this :thinking:

BUUUUTTT… You see the solution is a temporary one… VERY temporary.
I had to play with the colours to distract the spectators eyes from the additional flaw I get.
Sadly the screen also does it’s “I am only half way textured” stunt when ever I have to fill in any sort of input (Nope no problems with toasts/alerts/confirms or any other messages. Just the keyboard).
This is what happens :face_with_raised_eyebrow:

As mentioned: I tried to hide it with colour play… So you don’t directly notice it: But it is very there.

In your own time dearest… It’s great just getting feedback as is :+1:t2:

Lol… Well hey you are the mythical one among us… So thus are of course susceptible to comprimisations :smiley: :wink:
But alas m’lady fabled: descry my whimsy attempts to bring you data…
(So sorry: I just always have a smile reading anything from you thanks to the “coolest ever” mental image I have of you… You rock girl! :unicorn: )

Now just as a brief intro: I have a few different psudoPages where it is just actually a play on visibly of containers… This one is the “logIn” container.
Sooo I filled in my credentials and…

In retrospect: An emoji of sort would have been very fitting in this screenGrab :confused:
Sort of rushing to send over a reply ASAP…

None the less: to my defense of being too stupid to not have checked for errors on the browser… I am more of a Firefox user and for some reason getting onto Chrome to best experience you guys; I was not in my terrain.

Now when I check on the details…

I get something like this:

iframe.js:271 Info: The current domain is not authorized for OAuth operations. This will prevent signInWithPopup, signInWithRedirect, linkWithPopup and linkWithRedirect from working. Add your domain (platform.preview.appgyver.com) to the OAuth redirect domains list in the Firebase console -> Auth section -> Sign in method tab.
Ok @ iframe.js:271
(anonymous) @ iframe.js:535
e.Cd @ iframe.js:119
Rf @ iframe.js:122
Nf @ iframe.js:122
E.tk @ iframe.js:121
yf @ iframe.js:114
Promise.then (async)
tf @ iframe.js:114
xf @ iframe.js:114
Of @ iframe.js:121
Af @ iframe.js:120
(anonymous) @ iframe.js:114
(anonymous) @ iframe.js:333
(anonymous) @ iframe.js:329
hi @ iframe.js:197
h.dispatchEvent @ iframe.js:196
Ej @ iframe.js:239
wj.ol @ iframe.js:237
wj.ij @ iframe.js:236
XMLHttpRequest.send (async)
wj.send @ iframe.js:234
rm.Ol @ iframe.js:329
ym @ iframe.js:327
(anonymous) @ iframe.js:333
E @ iframe.js:114
Dm @ iframe.js:333
(anonymous) @ iframe.js:341
e.Vc @ iframe.js:118
Rf @ iframe.js:122
Nf @ iframe.js:122
E.tk @ iframe.js:121
yf @ iframe.js:114
Promise.then (async)
tf @ iframe.js:114
xf @ iframe.js:114
Of @ iframe.js:121
Af @ iframe.js:120
F @ iframe.js:115
R @ iframe.js:341
Jm @ iframe.js:333
(anonymous) @ iframe.js:530
Jr.start @ iframe.js:529
Kr.start @ iframe.js:530
Mr.start @ iframe.js:532
Pr @ iframe.js:534
(anonymous) @ iframe.js:535
ai @ iframe.js:195
b @ iframe.js:193
load (async)
Xh @ iframe.js:192
Uh @ iframe.js:193
(anonymous) @ iframe.js:535
(anonymous) @ iframe?apiKey=AIzaSyAfIZ6nYi8Qi7J0Ih22E4MgDSGvUap15i4&appName=[DEFAULT]&v=8.6.5&usegapi=1&jsh=m%3B%2F_%2Fscs%2Fapps-static%2F_%2Fjs%2Fk%3Doz.gapi.en.ILxaxn5iF9E.O%2Fam%3DAQ%2Fd%3D1%2Frs%3DAGLTcCP4GH4pdEaIiZe1k-cWfBRo9KTiAQ%2Fm%3D__features__:8

This is all VERY odd as since every other device: logs me in. EVEN ones I have installed the preview app later (To just eliminate the thought of maybe my catche data logging me in some how)…

Same dummy user… Same page… Same time period (ish).

When I create a new project: I do not get this… I have to fully replicate the conditions I mentioned earlier… And as much as a lot less interesting and non magical a mortal I may be; I sort of need to postpone it for a few days.
But if I get to it you will be the first person I shall be informing.

Thank you once again for all your time presented!

Please note: I am a bit overworked without stop/sleep/rest for about two days with an added (give/take) a few hours as coffee/toilet breaks… rendering me into a format many tend to claim me to be more of a clown than pretty much anything else :confused: … In fact got to get back to it before the sun is up :sweat:
But before I do so I had best present my disclaimer with my apologies have I crossed any lines

Hi! Don’t worry about how quickly you are able to answer, take care of yourself.

I was not able to reproduce the first bug you reported. Check that the background image is set to repeat and there is nothing preventing the container from growing. See below.

As for number two, from the error it seems like you should do as the error says :smiley: go to your firebase console and add the platform.preview.appgyver.com to accepted redirect domains and it should start working on web as well.

1 Like

Oh no, no, no… Mevi; the images (As your mention: already set to repeat) in mention are not BG images for a container but an image as is.
Though I am not TOO certain if it would make much a difference (Now having so many tests done: I am afraid I know the answer)

In retrospect: feeling rather dunce for not placing a “master container” to rule them all at the back. As that would have made a few things easier… None the less I did what I did and used images instead… (Yeah I am the “no play and work all day Jack” becoming a dull boy in real life… “Dull” being not too bright… Not as in boring. That I am SO NOT :upside_down_face: )

Firstly: Thank you so much dearest for all your time… But PLEASE tell me what it actually may be that I am doing wrong…

EVERYTHING had done WAS with repeat…

I have tried stretching to screen size. Absolute positioning… relative positioning… setting to screen/View/window sizes respectively (Even set a toast to tell me which one was the greater… Turns out width is though pretty much uniform. “Live and learn” :slight_smile: )
I imaged it… I containered it (Yes: it IS a verb too :wink: )… deleted all my elements… set up a new app… All with pretty much similar results.

Tonight to be able to present you some pretty pictures I gave it another go.
This is a classic attempt I did MANY times… the “Was the image a bad one?”…
Nope… Though you see only two here: many have been tried

container in container… with/without paddings… well same story.

This one coming up below could have cost me a lot… “deleting everything in the project” (MAN I LOVE how stable "history rollback works with you guys).
BTW… I tried to make different forms/shapes to not have them always look the same. As since they pretty much: DO :confused:

New project/application fort totally fresh start…

The ONLY “best scenario” result I got was to upload it in higher res and STRETCH it
(Which is NOT the point… And in case you are wondering… Uploading a supersized image or pre-tiled image: does not work either with screen borders)

Now that I got SOIMETHING happening… I gave all other formats a try. They all were pretty much stable other than “repeat”.

With 128px tiles…

I tried to see if setting borders on it would change anything… Well the borders conform pretty well at least… And I can validate that the container IS growing…

Here I was actually creative… I set the BG image of the container to a formula. Sooo… I was able to have it set when I was already on landscape (To sort of replicate my initial problem I had had told you of)
With a container: I couldn’t replicate it

But with an image file… I got rather identical results… But this time ALSO pulling the “working” stretched container tile with it.

Most OBVIOUSLY you are doing something right

But I am not… I do not know what it is.
If anything else comes to mind to why I have such a “stable” record of so such Back-ground image tile results I am all ears! (Or eyes… )

I put a lot for you to read… I am just too much into details by nature. I hope they tell something more to you than they do to me.
(Hey documenting these was not much fun either :upside_down_face: )

Dearest… sadly that did not help me at all… I kept getting errors of the like of
DevTools failed to load source map: Could not load content for chrome-extension://liecbddmkiiihnedobmlmillhodjkdmb/js/intercom-link-expand-loader.js.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
even still after it.

The only solution I got was to remove the initialize firebase flow from the global canvas… reset my connection the “old-school way”… This pretty much resolved my logging in in the preview web app. But with a cost of a good amount of time loss. I maybe had best just leave it be. But I wanted to be sure the app was in well working order.
None the less it seems it has actually been clearly documented that I was supposed to use only one connector. Somehow whilst uploading some data or somehow: I crossed this limit and lost support (Albeit it still worked with the phones)

Well you already have a LOT to go through above… And I am only one of your many people you have to deal with.
Please believe that I acknowledge the help provided and appreciate it greatly. Thank you!

Seems like there is a bug on Android regarding the image sizing, the same example that worked on iOS did not work on Android. I’ve filed a bug report for that, but it’s likely to not be fixed quickly, so I would recommend using a workaround for now.

Good thing you figured out the login!

Please keep it professional, I just work here :slight_smile:

:neutral_face: ??
I think you are referring to the “dearest”…

Sadly: I get that a lot :confused:

In Turkish there is a phrase called “Canım” that I can simply not translate to any language without a paragraph (or two/three/more).
It is of course pretty much like saying rakkani/kultaseni in how possessive it can be; BUT in it’s ability to add warmth/sincerity it is used very often where you have to consider the meaning mostly from the rest of the context.

Through habit it comes out as “dearest” when I type fast/talk without much thinking… as it is as closer in syntactic usage as in compare to “dear” that my habit tends to hold onto…
Yes: I get similar/worse reactions when I casually use “rakkaani” as well :sweat: (once again: without thinking).

I will re-read anything I shall write to you now on-wards to ensure I keep it to your preferences.

Then please do take note that there is another possible bug once again (I reppeat: “possibly”) android specific that may need attention.
I have tested with a few Android phones as judiciously as best I may… And as it simply failed in all instances. For sufficiency in thoroughness: I have not yet tested with ios, and this week I shan’t be able to.