Bug w/ Setting App Variable on Android

I’ll cut straight to it - when I’m trying to set an app variable on page mount, this does not work on Android, however, it does work on iOS. It only works when I’m tapping a physical component, not automatically.

That sounds strange! That definitely should work.

Some questions to help us narrow down the problem:

  • What is the type of your app variable (“Text”, “Number”, something else?)
  • What kind of value are you setting to it in “Set app variable” flow function?
  • How did you check that the variable was not set correctly?
  • Are you trying this out on the AppGyver app from Google Play and if so, what is your current version?

Apologies for seemingly ignoring you for 8 days now.

  1. It’s a Web URL variable, I believe.
  2. I am setting a Web URL variable. I know I am not doing anything wrong on my side because it works on iOS.
  3. I created a text field that reflected the variable on Android and it resulted in about:blank being shown. I then created a button to set the variable manually, and that did work.
  4. I am using the AppGyver Google Play app on the latest update.

Also, I know it’s not my device because I also tried it in an emulator and it still didn’t work.

Thanks for the help.

Is it possible to share the URL?

I have no idea what happened, but I somehow fixed it. I basically just re-did my workflows till it worked. :man_shrugging:


I think I know what happened…for some reason, I had to add a delay when setting the variable (1-2ms) on page load. I think this is because the webview is referencing that variable when loading, so there was a conflict :man_shrugging: