Build Android apk Error: 'react-native-webview-bridge' on ''

Hi Team!!
Error where: [workspace configure] You’re missing defaultTargets in your config /Users/ec2-user/app-builder/STAGING/dotappgyver/renative.json. Let’s add them!

I’m not using any plugings or data! I tryed see if my layout was having some conflits but haven’t found.
runtime version 3.3.3
I could have a first built, but the next time, same day, it fail. I’ve update my app with one new page and a button on menu page.

the first successfull built was runtime version was 3.2.15 and I am using the same keystore file.

Tryed lots of things, not yet. please any one might help me please ??

I have the same error, I used the last 3.3.3 version and tried again with the 3.2.15 that worked for me before but it didn’t work either. Anyone knows what should we do?

Thanks

This is the error part:

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘/Users/ec2-user/app-builder/STAGING/client/node_modules/react-native-webview-bridge/android/build.gradle’ line: 38

  • What went wrong:
    A problem occurred evaluating project ‘:react-native-webview-bridge’.

Project with path ‘:react-native-webview’ could not be found in project ‘:react-native-webview-bridge’.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

I’m having the same error… Must be something wrong with the Android build service

@Mevi could u please take a look at this for us…

@German_Castano @Frederico_de_Lima have u guys found the solution for it ?

Unfortunately no @YakovTran, I think only an AppGyver team member could help us. I’ve tried building with different runtime versions and it doesn’t work even when the app runs great in the testing

Ok, please inform if one of us be able to make it…

I found this ticket sent to AppGyver @YakovTran @Frederico_de_Lima you can vote for this bug as well Unable to build the app | Voters | AppGyver

@German_Castano yes, I voted, thanks !

So weird but it worked for me ! Let’s install the Webview component and somehow it will fix the issue !

1 Like

Yes, it’s weird but It worked. nice catch Yakov

How do you mean Yakov?
how do you install that?