Build failed (deprecated Gradle features?)

@Andrew_Ganine we’ll try to find out what’s causing the keystore error, I’ll let you know when there is an update. @Steven_Mills I’ll update you in the separate thread regarding the error you’re getting.

Thanks, @Mari. I would appreciate if you could look into this ASAP - we’re ready to launch the app, but this issue is blocking everything.

1 Like

Hi @Andrew_Ganine, we unfortunately weren’t able to produce much more insight to the keystore issue here, it should work if you first make sure you have JDK 15 instead of any newer one (in docs: Note that using JDK 16 to generate the keystore file seems to cause build failures. Please use JDK 15 instead!) and run keytool -genkey -v -keystore <keystore_name>.keystore -alias <keystore_alias> -keyalg RSA -keysize 2048 -validity 10000

Hi @Mari , I did exactly that. I tried JDK 15, 15.1 and 15.2, all to the same effect. Here’s my keytool command:

keytool -genkey -v -keystore activechat.keystore -alias activechat -keyalg RSA -keysize 2048 -validity 10000

Could you please look into this again? Maybe trying to run a build with your own key? We’re locked in the development, does it mean that we should give up and switch ApppGyver to another tool?

Please help!

@Andrew_Ganine, if you run keytool -v -list -keystore activechat.keystore, what’s the “keystore type” and how many entries can you see there? Is the alias name correct?

We tried running this with your keystore file locally and got the same error as in the build. If you run java -version what do you get?

Hi @Mari , thank you for your help!

Here’s what I get from the first command:

  • checked by Mari, removed the sensitive info!

Does this help? Any ideas on what I could change/fix?

Thanks, your help is really appreciated. After some research it looks like AppGyver is unique in terms of features and flexibility.

Hi, looks like your keystore is in PKCS12 format instead of JKS (likely because of the Java 17 version, so the same issue applies as with JDK > 15), you can try including the storetype in the command:

keytool -genkey -v -keystore <keystore_name>.keystore -alias <keystore_alias> -keyalg RSA -keysize 2048 -validity 10000 -storetype JKS

and then run keytool -v -list -keystore <keystore_name>.keystore again to see if the format is correct :slight_smile:

3 Likes

There’s also instructions here on how to convert an existing PKCS12 keystore file to JKS.

@Mari you are amazing! Thank you, “Build completed” now. Love the support your team provides, many thanks!

4 Likes

Awesome to hear! What a hard problem to spot, we’ll definitely include support for the other keystore format in the future. :slight_smile:

1 Like

@Mari covered me too!
@Andrew_Ganine I had that same problem with keystore also, so thanks for posting, i fixed two issues in one sweep!

Happy Dev-ing Andrew!

1 Like

Great to know it worked for you also, @Steven_Mills !

AppGyver has two great assets - product and team.

1 Like

Hey @Mari , could you please check what’s going wrong again? I get a message “Build failed for unknown reason”, and I’m just trying to rebuild the app with 3.3 runtime to fix the “input field not clearing itself” bug.

The app is AppGyver - Composer Pro

Here’s the log:

FAILED with ERROR:

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘/Users/ec2-user/app-builder/STAGING/client/node_modules/react-native-webview-bridge/android/build.gradle’ line: 38

  • What went wrong:
    A problem occurred evaluating project ‘:react-native-webview-bridge’.

Project with path ‘:react-native-webview’ could not be found in project ‘:react-native-webview-bridge’.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

Hi @Andrew_Ganine, we’re aware of this issue and it’s currently under investigation.

2 Likes

Adding the webview component from the component market solves the problem.

2 Likes

Hi @Andrew_Ganine, great to hear that you found a solution. We’ll keep working on addressing the root cause of this.

1 Like

Hi Andrew,

How did you add this? What did you need to replace with this component? I have the same error.

My app is running fine as a web app but the Android build is failing.

Thanks for any assistance or pointers.

1 Like
  1. Install the Webview component from the component market (in the left panel, on top)
  2. If you do not need a webview in your app, create an empty page and drag that component there (just installing the component is not enough, it has to be present in the app).

Hope that helps.

3 Likes

Thanks Andrew. That seems to have fixed that issue.

It has now stepped on to another one, Wrong bundle identifier in google-services.json. I will see if I can work that one out now :slightly_smiling_face:

2 Likes

This helped me too! Many thanks
I suggest to update the documentation at

so it will be easier to reach the solution …

1 Like