Build failed for application

Hi support!

Have tried to build an APK twice but unfortunately it goes wrong somewhere along the way. Got a log sent to me, but there is not much I understand there :slight_smile:
Anything you can get help with?
Applies to app 121732

I have changed the name of the app, if this has anything to do with.

No response? There must be more than me who have this problem? I created a brand new app and made no changes to it, then I tried a build. But even this one got the same error.

Ah, sorry for not updating you on the process. Your build error was something we haven’t seen previously with any app so it takes a little more debugging to figure out the core issue. We’ll let you know asap when we have the answer and a fix for this, sorry for the inconvenience.

Okay, great! Hope you find the error. Wish you good luck. Starting to love Appgyver, so hope this does not become a bump in the road.

What is dolan.json?
error platformAssets/runtime/dolan.json: Unterminated string constant in file platformAssets/runtime/dolan.json at 19161:27. Run CLI with --verbose flag for more details.
Error: Unterminated string constant in file platformAssets/runtime/dolan.json at 19161:27

We store app data as dolan.json and during build app data is read from it.

Just an update also: As your problem is a new and odd, I’m unable to debug it myself. And at the same time the ones who could do the debugging have been really busy, so I still can’t tell you what the issue with your build could be. But it’s still high on to-do so it’ll be checked as soon as there’s little more room in the schedule.

Okay, I understand.
Just want to mention one strange thing I see in the app, do not know if it may have something to do with the error … I have had two local databases that I no longer use, and have deleted these early in the development of the app. But they hang around a bit in the background and want to be reminded of there selfs

when I want to do something with the databases I use. see attached picture.

The databases “Database1596919207769” and “Database1596922712712721” are not used, its deleted.

Hi, do you mean that you have deleted the Data resources from the Data resource tab (see attached image)? Or have you removed those only from the page?

image

Hi!
I have removed the databases from the Data resource tab. I do not use them all in the app.