Build Service - iOS app Build Error when using [Get Firebase Device Token]

Its been reported already but Im just going to make this a new topic since its specific to Build Service.

Error occurs when using the [Get Firebase Device Token] flow function, which will prompt to upload the GoogleService-info.plist file in Advance iOS configuration. The iOS Build then fails with error using the newest runtime 2.8.31.

Here is my error log:

[!] CocoaPods could not find compatible versions for pod “Firebase/CoreOnly”:
In Podfile:
RNFBAnalytics (from /Users/ec2-user/app-builder/STAGING/client/node_modules/@react-native-firebase/analytics ) was resolved to 7.4.2, which depends on
Firebase/Analytics (~> 6.28.1) was resolved to 6.28.1, which depends on
Firebase/Core (= 6.28.1) was resolved to 6.28.1, which depends on
Firebase/CoreOnly (= 6.28.1)

RNFBApp (from /Users/ec2-user/app-builder/STAGING/client/packages/app-standalone/node_modules/@react-native-firebase/app ) was resolved to 8.2.0, which depends on
Firebase/CoreOnly (~> 6.27.0)
[ warn ] [configure] pod install is not enough! Let’s try pod update! Error:
COMMAND:

pod install

FAILED with ERROR:

[!] CocoaPods could not find compatible versions for pod “Firebase/CoreOnly”:
In Podfile:
RNFBAnalytics (from /Users/ec2-user/app-builder/STAGING/client/node_modules/@react-native-firebase/analytics ) was resolved to 7.4.2, which depends on
Firebase/Analytics (~> 6.28.1) was resolved to 6.28.1, which depends on
Firebase/Core (= 6.28.1) was resolved to 6.28.1, which depends on
Firebase/CoreOnly (= 6.28.1)

Command failed with exit code 1 (EPERM): pod install