Build Stuck at Queued for 20+ hours

I tried building my app today and I am stuck at queued from past 5+ hours.

I tried doing it again and again and now I am stuck with 5 max build limits.
It is mostly not my apps problem because I just made an apk yesterday and it worked fine. The problem started today and I am not able to figure out what happened. I even made it go back to previous build state but that didn’t help either.

If it isnt cleared yet id recommend raising this as a bug. If it helps i usually try to build a different runtime, then a different app type (like web app) to see if it “pushes them through” though I doubt technically speaking that is what actually happens.

Ok will try with the web app.
One of the 5 builds failed and this is the error I got

only the latest 4.9.72 runtime build works. So avoid the previous 3.

I tried those too. They are also stuck at queued.



You have queued quite a lot of builds. Please be patient with builds and avoid queue’ing if you think the previous one is “stuck”. To resolve the issue, I would advise you to wait for all builds to finalize before launching another one.

To add to the error you have experienced: currently, 4.9.72 runtime is the only one working.

Each build is at a difference of 3 hours as the previous ones were stuck. The old ones are stuck for around a day now. I even tried web app, that is also stuck at queued. And only one of the build failed, that was on 4.7.37, which on further checking, I came to know that is bugged out now. My. 4.9.72 are still stuck at queued.

Firstly, if the 4.9.72 is the only runtime running, you guys should hide all the other runtimes. Secondly, even the 4.9.72 build is also stuck at queue

The other runtime versions are not buildable due to a 3-d party dependency. Once they resolve their issue, the runtimes will work again. It was heavily requested not to “jump” between version, but rather leave the old ones for some time.

As for the queue issue, we are currently looking into it.

Sorry, didn’t knew about changing clients.
Thank you

Same issue here. Already more than 4hrs since i tried building with 4.9.72 and 4.7.37. Status are both queued.

App iD: 566467


1 Like

I started one build yesterday at around 12 noon. Still stuck right now. Still queued. Only 1 build.

Any updates on the build time? I wanted to check my app’s notification settings, that requires a build. Thank you

1 Like

One of the builds failed after 10 hours.
This is the error message I got:

Others are still stuck at queued.

My buildings are taking at least 5 hours, but i have one stuck for more than 12 right now. I believe is a bug, there is no reason for it to take so long. Im using the last version and I have only one build queued.

1 Like

almost 3 days and my build is still stuck!!
What’s going on?

1 Like

Any updates on the build queues?


We have applied a fix, all queued builds should finalize soon.


Thanks; still 2 builds are in the queue since yesterday:

1 Like