Build with version 2.8.28

I’m trying version 2.8.28 in appgyver preview and this version has fixed a lot of bugs in my app so I would build up an apk and distribute it to my collaborators.
I’ve opened the build center but I cannot choose version 2.8.28 as engine builder
The only option are 1.9.x or 2.6.8
Why is not possible to build with the new version?

Probably because 2.8.28 hasnt been certified as “stable” yet. Its still technically “beta” i would assume.

In changelog has been marked as released and not as beta anymore

2.8.30 is now available in builds.

I confirm! Thanks Dan