Building IOS got error

Error Message:
Please Help. we need this asap. thank you very much.

Runtime version: 4.6.11;
AB version: 1.7.6
COMMAND: ASSETS_ARCHIVE_URL=https://appgyver-meap-assets.s3.amazonaws.com/lo8g7d9kurar1lfewzmjkinu7ttt?response-content-disposition=attachment%3B%20filename%3D"assets.zip"%3B%20filename*%3DUTF-8’'assets.zip&response-content-type=application%2Fzip&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJJSXXQRL4UNGBAXQ%2F20220914%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20220914T021335Z&X-Amz-Expires=604800&X-Amz-SignedHeaders=host&X-Amz-Signature=831c91d01f431cfd0663f5bc7220a6597c0abe197394dfc9c51a905c0431d562 npxrnv export -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.6.11 -r --xcodebuildArchiveArgs “OTHER_CODE_SIGN_FLAGS="–keychain\ AppGyver-342973"” FAILED with ERROR: FAILED with ERROR: [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # Error: Command failed with exit code 1: pod install Analyzing dependencies Fetching podspec for DoubleConversion from ./node_modules/react-native/third-party-podspecs/DoubleConversion.podspec Fetching podspec for RCT-Folly from ./node_modules/react-native/third-party-podspecs/RCT-Folly.podspec [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # at makeError (./node_modules/execa/lib/error.js:60:11) at handlePromise (./node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) - Executing: pod update :heavy_multiplication_x: FAILED: pod update ┌──────────────────────────────────────────────────────────────────────────────┐ FAILED with ERROR: [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # Error: Command failed with exit code 1: pod install Analyzing dependencies Fetching podspec for DoubleConversion from ./node_modules/react-native/third-party-podspecs/DoubleConversion.podspec Fetching podspec for RCT-Folly from ./node_modules/react-native/third-party-podspecs/RCT-Folly.podspec [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from ./node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # at makeError (./node_modules/execa/lib/error.js:60:11) at handlePromise (./node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) │ [ error ] [configure] COMMAND: pod update FAILED with ERROR: [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from /private/var/folders/pf/p5g2vb2j0yx1x6vlmxdppc700000gn/T/342973-ios-243843/node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from /private/var/folders/pf/p5g2vb2j0yx1x6vlmxdppc700000gn/T/342973-ios-243843/node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # Error: Command failed with exit code 1: pod update Update all pods Updating local specs repositories CocoaPods 1.11.3 is available. To update use: sudo gem install cocoapods For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at Release 1.11.3 · CocoaPods/CocoaPods · GitHub [!] Failed to load ‘RNFBMessaging’ podspec: [!] Invalid RNFBMessaging.podspec file: No such file or directory @ rb_sysopen - …/app/package.json. # from /private/var/folders/pf/p5g2vb2j0yx1x6vlmxdppc700000gn/T/342973-ios-243843/node_modules/@react-native-firebase/messaging/RNFBMessaging.podspec:3 # ------------------------------------------- # package = JSON.parse(File.read(File.join(dir, ‘package.json’))) > appPackage = JSON.parse(File.read(File.join(‘…’, ‘app’, ‘package.json’))) # at makeError (/private/var/folders/pf/p5g2vb2j0yx1x6vlmxdppc700000gn/T/342973-ios-243843/node_modules/execa/lib/error.js:60:11) at handlePromise (/private/var/folders/pf/p5g2vb2j0yx1x6vlmxdppc700000gn/T/342973-ios-243843/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) │ │ │ Project location: │ │ ./platformBuilds/standalone_ios/RNVApp.xcworkspace │

This issue resolved . thanks

–Chris Revell
Hi All, so we managed to get a successful build.

After adding the ‘Get Firebase device token (beta)’ as suggested by Pekka I found that an additional dependency was missing under the advanced build configuration settings (GoogleService-Info.plist).

Why it doesn’t warn that there are missing dependencies when performing the build is beyond me…

Anyhow, if you guys are still having issues:

1- Install ‘Get Firebase device token (beta)

2- Generate the GoogleService-Info.plist from the Google Play Console

3- Ensure you go in and add the GoogleService-Info.plist file to the build settings.

Thanks all :slight_smile: