Built & published a web app but just get a blank page

I built and published my app as a web app hosted at appgyverapp.com but when I launch the URL, I just get a blank page. I’ve tried selecting all of the plug-ins that I could image being needed and tried it again and changed the subdomain URL to avoid the 24 cache issue but still get a blank page. Any thoughts on what I could be missing?

There are issues with the web builds for 1.8.3-beta1 tag – would it work if you build it with 1.8.0? What’s the app ID in question?

Sorry, I forgot to reply to my own post - I did get it working with 1.8.0. Is there any way to do some type of local storage with a web app? I see that the local storage data source doesn’t work (not unexpected) but is there any other way to store a limited amount of data locally? I need a couple of config vars that persist locally between app runs.

Client-side data resource should definitely work on web – are you sure you’re not hitting https://tracker.appgyver.com/bug-reports/p/developer-can-erroneously-remove-id-property-of-a-client-side-data-resource by accident?

There’s also the Get item from storage and Set item to to storage flow functions: https://docs.appgyver.com/reference/flow_functions/storage

Hmmm, I definitely have an id property on my local data source but since I’m only using a single record to store some persistent data, I am just hardcoding it to “appData” and using that to read and update. Do you think that’s the issue? I also tried Get Item from storage and that seemed to fail as well.

I figured it out. I wasn’t creating the record if it didn’t exist the first time.

1 Like