Cannot access single record data from Airtable

Regular list to details page setup. Collection data displays as intended.

Page id parameter is sent successfully and everything looks good (green tests, preview data, composer looks good) but empty fields in preview apps and macos. Built schema from test of single record GET.

"debug data: " + ENCODE_JSON(data.Airtable_fvst1_single.Body) returns empty as well.

I’ve tried all kinds of ways to setup the data on the details page, ran through formulas, run out of ideas.

Anyone, please? It’s the most basic thing but seems impossible with Airtable?

Actually Airtable is one of the easiest to set up. That being said, you need to provide some screenshots in order to get an idea what are you trying to do and where you got stuck.

Thanks so much for getting back to me:

Here’s the preview window on the left, which doesn’t pull the data - and on the right you can see Composer successfully pulling data.

Here’s some screens of what I did:




Data is read fine by Appgyver and the previews are all good. They just don’t make it out to production for some reason.

I solved it by rebuilding from scratch. No idea were the error was.