Can't get basic dropdown to work?

I had a Dropdown that worked just fine, but I changed the “selected value” to be an app var from a page var (both of type text), and now it doesn’t work. When I first tap the dropdown, it shows the option list values as expected, but when I tap one, it just shows the placeholder text (“Select” in this case.) And then when I tap it again, the only value in the option list is “Select.”

In the debugger I can see that the app var is successfully being set, so why isn’t the Dropdown reflecting the new value? And why is the option list being cleared out? The app var I used to hold the Option List values and labels still has the same options in it, so it isn’t a matter of the source data getting cleared somehow. The labels and values are identical to each other, btw, so it doesn’t matter which one gets shown.

The only thing I did to the dropdown was populate the Option list via a formula and set the Selected Value to an AppVar. Am I missing something? Seems like this should work.

App ID: 169788, testing in Android Preview app and Web preview, runtime 2.8.28.

Video of the behavior:

Settings for the Dropdown:

Option list formula/values:
FireShot Capture 2165 - Crawl Scorekeeper - Composer Pro _ platform.appgyver.com_ -

Same here. I posted about it a few days back but I didn’t get a response. Nothing changed in my app. Last build, which was about a month ago, it worked fine. Now, I’m seeing what you’re seeing.

I used to have problems using the Dropdown Field. I changed to the Dropdown primitive and problems went away.

I tried to do this with the primitive, too, and saw the exact same behavior.

Thank you for this post. I have spent nights on this also. Was going to post the same question. Once I click a value in the dropdown the option list disappears.

I’ve reported this in the Bug Report area:

Please vote for it!


I’m getting the same. I had created a bug report (Page variable (list of texts) breaks when setting one item as app variable | Voters | AppGyver), but I just upvoted yours, @Joel_D. Yours describes the issues better.

Edit: @Harri, @Mari, @Kristian_Gerkman It’s also worth noting that this breaks the app I’m building. If the user can make selections, they can’t get through the workflow, and I’m not seeing an elegant way to use checkboxes, etc instead. I’m currently looking into building my own dropdowns from scratch–a container with two containers inside–one for the selection and another with the list. Visibility toggles from one container to the other as the user clicks. But I would love if I didn’t have to rebuild all the dropdowns throughout the app. I wonder if this bug might be worth escalating?


Thanks everyone, found the issue and pretty simple workaround! instead of having the MAP formula on the dropdown value list, you can add an intermediate page variable that you set with the MAP formula - I’ll escalate this to be fixed ASAP!


This is now fixed, no need to update anything!


Yep now working for me, thank you for saving my sanity.

“Our hero” == “@Kristian_Gerkman