Cant retrieve from firebase realtime (cors error)

i really dont know whats going on, the rules are like
image
this and i cant retrieve any data

image

image

do you have any idea??

Hi,
This is purely a Firebase related question, so we are unable to assist much. After looking at the Realtime Database Docs, I would suggest that you use ‘true’ and ‘false’ in the rules instead of the dates:

{
  "rules": {
    "foo": {
      ".read": true,
      ".write": false
    }
  }
}

Again, nothing, actually, im asking more to see if im using the correct url for ex
But thanks

Do you use the same url for the realtime ?

Nope, I use the reference url, that you can copy from firebase here:

That returns correctly on the “test” button in rest api configurator.

That’s really strange i get this cors error

Actually, im pretty sure its my rules, can you share yours?

Yeah, I got the same error… I am still just trying to get my way around the realtime database. So maybe I am not the best one to help you out with this now. But I’ll get back here when I get something successfully done here.

1 Like

oh, ok , lets see if anyone knows

Something should had stuck, because now it works…
As Mihaly said,

1 Like