Card shadow not appearing on preview

My shadows aren’t showing up on my preview. Is that just because it’s a preview? Or are shadows not fully functional?

In builder:

in the AppGyver app previewer on my phone:

Will have to dig into this – what Android device and OS version are you running on?

Nexus 5 Android 8.1.0


Hi @Harri_Sarsa! Just checking in on this item. I was able to work around the issue by putting the elements into a card (rather than a container with shadows). So that you guys have all the clues to (fully recognizing you probably have more urgent issues as priority):

  • Card shadows showed up in the previewer; container shadows did not.
  • Container border also did not show up in the previewer.
  • This was true on my Nexus 5 and my husband’s Moto X.

Thanks so much for the extra info, we’ll look into this!

Hello, any news in this topic?

I have the same problem with preview iOS.

I can see the problem is with marketplace card component. When I add normal card from Core tools it’s ok. When I add card component from marketplace can’t see shadows in preview.

@Erin_Wagner @Harri_Sarsa Ok got it working. You need to change “Overflow” to “Visible” on Card component.

1 Like

That fixed it! Thanks you sooo much @Wojtek! My app is going to look WAY better now that I understand how to put shadows on things.

Has this issue been fixed for containers? I have a number of containers that should have shadows around them and I can see them on the composer but on iOS they do not show up. I see I could use a card but already have everything set up with containers since I had an issue changing the background color of cards when setting everything up.