ComboBox: unable to select item

Hi,

I am trying to use the combo box from the marketplace and so far I am able to input text and it automatically searches in a list from an odata endpoint.

But if I want to select an entry like in the normal dropdown component it seems to not work. Is it maybe related to how I bind the List?

MAP(data.Products1, {label: item.name, value: item.name})

I also tried without label and the direct mapping:

It seems that opening the combo box dropdown and then selecting works, but not if you type and then want to select an item.

Thanks :slight_smile:

Hello,

When you type something and open it are there any filtered options? So when you click a filtered option nothing happens? Combo stays open and typed text doesn’t change?

Which platform web/android/ios?

Can you try make a dummy page variable list of objects with a text field, bind to it, and see if that also doesn’t work?

Is your input value bound to something?

Hi dwidge,

I tested on android and my input is bound to a page variable. Created a dummy page and there everything was working fine.
It seems that you have to double click the item in order to be selected. Previously I always did 2 clicks with a pause in between.

Thanks that solved it for me. Did you use the combo box in the past yourself? While testing my app crashed multiple times mostly if I delete the text in the combo box again.