Compass showing -1

Hmm, I’m not sure :thinking: Can you try without the VPN? Perhaps that is confusing the location of the phone.

Oops,

We may have lost ourselves in the forest.
However, there is no forest without an entrance.

See also the attached image.

Tanron_JP

We will search for the entrance, although it may take some time :relaxed:

Please try if one of the following would fix it:

  1. Are you pressing the paragraph or button where the “start compass poller” logic is?
  2. Try using Get single compass value flow function instead of Start compass poller. Does that work?
  3. Try to uninstall AppGyver Preview and reinstall it again.

If none of those work, answer these questions:

  1. What is the device you’re using and the iOS version?
  2. What is the AppGyver Preview version?

Thank you for investigation.

See also attached image.

Please try if one of the following would fix it:

  1. Are you pressing the paragraph or button where the “start compass poller” logic is?

Yes, I pressed button where the “start compass” > fig1,fig2

  1. Try using Get single compass value flow function instead of Start compass poller. Does that work?

Despite I tried this process it did not work > fig3

  1. Try to uninstall AppGyver Preview and reinstall it again.

I did reinstall, but it did not work. > fig4,fig5

If none of those work, answer these questions:

  1. What is the device you’re using and the iOS version?

iOS ver13.6.1

  1. What is the AppGyver Preview version?

AppGyver ver 1.9.22

I got the version from “App store”, how to get it from device?

Best regards,

Tanron_JP

Additional image.

Hi!

How disappointing that none of that worked :frowning:

Just a couple more, are you using a physical iPhone, or a simulator? In simulator, it would not work.
Below is a screenshot taken from my iPhone 11 iOS 14.0.1 using 1.9.22 AppGyver Preview. I checked also without mobile data only on wifi, and the result is the same.

You can get the runtime/client version from the Preview app by clicking on your email in the Apps view.

Hi,

We may have seen the entrance to this forest

Just a couple more, are you using a physical iPhone, or a simulator?
It’s using a physical device.

This week, I’m busy with my main business and incidental works, so I can’t take much time, but …

fufufufu (expression of how to laugh with a nose at japan)

I read the email from you and feel that the hint may be hidden in it.
That’s very important, but it hasn’t been picked up in our research process so far.

Well, I will give you a question.

What hasn’t been picked up so far?

Hint;
Why is the result “-1” instead of none?

Postscript:
If this is the root cause, we may consider differences in formula specifications in the future.

Tanron_JP

Good to hear that :relaxed:

I assume the -1 is because an error occurs. You can check this by e.g. alerting from the second output of the “Start poller” or “Get single value”, using the “output of previous node” to display what error message is given, or ENCODE_JSON(outputs["Start poller"].error) in formula.

Hello,

Perhaps this phenomenon from the architecture of i-Phone device.
In other words, even if the iOS version is the same, I guess that the architecture will be different depending on the generation of the device itself, and the formula used there will also be different.

Your device is i-Phone 11
Mine i-Phone 6s

Maybe that’s the case.

Tanron_JP

Hi! So sorry it took me so long to answer. I hope all the trees in the forest haven’t lost their leaves yet :pensive:

I’m afraid I don’t have an iPhone 6s I could use to test :thinking: However, if the iPhone version would matter, there wouldn’t be a formula to fix it, but it would be something that React Native itself would have a problem with. I tried to google a little, but did not find anything on this. If you have any other device you could try this on, that would be great, but if not, can you please share your app id so that I can have a look?

Perhaps you are on a long journey and I was wishing the safety of your journey.

I will prepare your recommended device in the near future.
However, we were also interested in the way we share the app, so
I tried to create your account.

Is this all right?

Via “Manage Users & Groups”.
ID & PW will be show at the additional file.
appgyver346

Best regards.
Tanron_JP

ID_.ods (11.5 KB)

Hi! I will need your app id to be able to access your app. You can find the app id in the URL of your app.

Hi,

Ooops, so Sorry.

147806

Tanron_JP

Hello! Sorry my answer took a while, I was sick for a week :frowning: I tried your app, but unfortunately perhaps, the Compass works for me (tested with AppGyver Preview 1.9.22 with iPhone 11 and iPhone SE(2016)).

At least now it is clear that your setup is correct, it’s only something with the device, either location permissions (either the app does not correctly request them or they are blocked somehow) or VPN (the VPN has settings that block location) that cause this problem. I tested with a VPN service, and that did not change the situation, I was still able to get the compass result. Here are again the settings for the iPhone SE, which had AppGyver Preview reinstalled and asked permissions for location.

Hello,

How are you feeling?
Don’t overwork it and take good care of yourself.

Hmm,
After all, was it a device-specific event?
If so, this issue should not be explored further at this time. Because this i-Phone 6s is a finished product.
With that in mind, you should close this case.
Thank you very much.

Postscript;
It’s Christmas soon.
I’m not sure if you saw it, but that additional user’s icon was a unicorn.
The image was captured from the product catalog of an eraser manufacturer.
https://iwako-global.com/product-list/single/

You can order that eraser from overseas as well.
However, the shipping cost is too high to buy individually.
If I ship after purchase using SAL, the cost is not a big deal.
That’s why I would like to give you that unicorn as a Christmas present, but how about it?
Of course, the destination is not the current address, but the cafe in the neighborhood.

Unicoon.png

Yes, unfortunately, it’s very device-specific and I don’t know how to help you further :disappointed: I’m sorry I couldn’t help you despite everything. Thank you for having all this patience with me.

I did see it! I actually showed our team also! I was so happy!

It’s very cute! In Japan, there are cute versions of everything. I actually have traveled to Japan several times, and was planning to visit again in Kyoto and Osaka this October, but due to global events I of course could not come.

Thank you for the offer, but I wouldn’t want to be any trouble to you. If you insist, you can send me a private message about it :relaxed:

Hello,

Oh!
You shared the image of that unicorn eraser with the team.
Well, that was good.

It was a pity that you couldn’t go to Kyoto.
However, COVID-19 will leave soon, but Kyoto will not escape, so it’s okay.

It’s a good idea, so …
I’m planning to include this as well, but please tell me your preference.
(Made in Japan)
https://www.kai-group.com/store/products/detail/12386

Regards,
Tanron_JP

Hi!

Thank you for the kind words. If you like, please send me a PM about this :relaxed:

Hi everyone,
I’ve the same problem with an Motorola G7 Android 10 phone; I followed the same steps above, but no data comes from compass. I double checked the Appgyver permissions: are all enabled.
The strange things is that the geolocation has the same behavior: It does not work.
My suspect is somethings has been broken after recent Appgyver updates because some month ago the same application to get my location on the same phone worked.

The problem seems to be related only to the conversion type.
See Geolocation stop working after Appgyver update
Using STRING(sensorVars.geolocation.latestValue.latitude) works.

1 Like