Components not displaying on page

New Issue has just arisen whereby I have a page with elements that I can see in the Tree but I can’t see in the canvas. See Pic.

I can’t actually work on my app properly until I can see what I’m doing!!!



This happens from time to time for me too, and I feel like it’s somehow tied to repeated elements?
Refreshing the editor page in browser has solved it every time.

Cheers - I’m glad I’m not alone - I refreshed the page and it was visible again!

We’ll have to look into this, haven’t noticed it ourselves. Let us know if you can find solid repro steps for this to happen. Thanks!

As Juuso said - it’s happened on two of my pages with repeated objects (both containers). Refreshing brings it back.

I have the same problem on 2 of pages that have a list of names/data from app data. Lists work on mobile but I can’t see them in editor. Plus the editor hangs every time if I try to add components (button, new list…) to those pages. All there is to do is to close browser tab and open the editor again. The problem persist after that but I can modify other pages.

edit: refersh worked for me too.

@Harri_Valijarvi so the freezing happens consistently? Can you share your app ID (in the address bar when you’re editing your app) so we could take a look and see if we can repro this?

Yes it happens every time and on two different computers. App ID 96981.

Yup, repros on our end too, will check what’s wrong!

This should now be fixed with release #133!

I was having the same problem. Yes… looks like it is fixed now.

1 Like