Configure Firestore data resource

I can’t edit my Firestore database, because buttom SAVE DATA RESOURCE inactive.

Help me ASAP

Снимок экрана 2022-01-27 в 22.11.39

If you share a wider screenshot someone may be able to see the issue.

screenshot added.

Button SAVE DATA RESOURCE inactive.

What I do wrong, or HELP with problem ASAP

There are some really good step by step guides. Its best you follow one of them closely. A big part of succeeding with Appgyver is searching for relevant threads and gathering the information relevant to your situation.

Search string “Firebase Setup”

Thanks, but it not relevant info.

I did add Connector this my Firebase is well, and create DATA RESOURCE - Google Firebase, as like in this guide: Google Firebase connector - AppGyver

All work is good, but yesterday I need to add new Firebase database to my app or edit is last databae - but button SAVE DATA RESOURCE is inactive.

Hmm :thinking: Not sure if this is related to your issue, but noticed while trying to figure out what could have caused your problem that for some reason older firestore data resources’ firestore collection name has been cleared… I asked the Composer team to investigate it.

I resolved this problem as off iOS app in firebase connector in AppGyver, and on only Web configuration, and SAVE DATA RESOURCES is active.

Отправлено с iPhone


I had the same situation (only the Android app existed on Firebase) and I solved it in the same way. I created a web app, configured it, and only allowed web app confuguration in the SAP build app ( AppGyver).

Thank you!

Asking for a friend who’s just faced this issue, is there an official reason why the Save button turns inactive when the iOS (or Android) app connector are toggled on? It happened overnight (and worked well before).