Could not upload font. Please try again later

Is this a bug or is it just me?
Cleared cache, tried a different machine, even tried other apps that I have but with no success.
I had installed a couple of other fonts but removed them due to preference issues. Those fonts were used by the app but replaced them with only one (pictured).
01
This is the message I get across all my apps and pc’s.

Hi @Edvin_Rushitaj, did you manage to resolve the issue? i am having similar issue trying to upload Google fonts.
Thanks

Hi Leon. Unfortunately this issue persists on all my apps. Maybe its a platform bug.
@Mari does this happen to other users as well?

@Edvin_Rushitaj @Leon it seems like it could be a bug. I’ve created a Tracker ticket for the issue here: Could not upload font | Voters | AppGyver

@Edvin_Rushitaj @Leon we couldn’t reproduce the issue, so we would need some more details to get to the bottom of this – could you provide us with app IDs where the uploads are failing, and which fonts you are using? Are you downloading from URL or using a font file?

Hi Mari,

My app id is 369652 and the font I was trying to upload is attached. Thanks

Exo2-Bold.ttf (130 KB)

Hello Mari
199805

the fonts varies and are ttf and otf. the problem appeared when i deleted a font which was used in a style. I dont know if this has to do with anything but as soon as i tried to replace it with another font, the problem appeared.

@Leon I was able to use the font in an app, so it might be something app specific or somehow related to your internet connection. I’ll follow up on the ticket here: Could not upload font | Voters | AppGyver

@Edvin_Rushitaj thanks for the additional info!

Also, uploading from url works normally but the font displays completely wrong, it seems like it is substituted with a default font no matter what font you upload.
Changing machines and internet connections doesnt work for me as i tried to upload them in different locations with different pc’s.

1 Like

@Mari I was able to upload fonts successfully through URL but not file upload. My internet connection works fine and using another PC doesn’t help. I am not sure what you meant by “app specific” as add font file is one of the utilities from appgyver.

@Leon thanks for the extra information. By app specific I meant that the issue is does not seem to be with the font you are using (since I was able to successfully upload it), but with the project – Edvin’s comment leads me to believe that you can somehow end up with the editor in this state if you first remove and then add fonts. Have you done that in your app?

I think that there might be a bug if you delete a using font by the app. But this doesn’t justify the fact that other apps are experiencing the same problem.
I dont know if this will help you, it appears that theres an empty slot when choosing fonts on a style.
Untitled-1

1 Like

@Edvin_Rushitaj @Leon one more question: If you perform the failing operation with the Chrome developer tools opened, (right-click + Inspect) do you see any errors on the Console or Network tabs?

I created copies of your projects and tried uploading fonts to them, but for some reason the error doesn’t replicate in the copied apps. That’s why I’m asking you to do this in the original apps. :slight_smile:

That seems strange. I created myself copy of my app but the problem persisted.
Anyway here’s a screencap of console when trying to upload a font.

the 400 post is as soon as i press the upload button*

1 Like

Hi, thanks, that info is very helpful. Seems that it might have something to do with who is uploading the font.

1 Like

Here’s my screen capture on chrome console and looks like it is blocked by CORS policy:

could this be chrome related issue?

1 Like

Hi, thanks, is that also when uploading the file or when using a URL?

The CORS error looks like it would happen with URL – the Google Fonts URL is invalid, it needs to point to a file that’s hosted online (ending with .ttf or .otf).

Hi Mari, the screenshot was taken for uploading font file and as mentioned, using URL has no such issue and fonts were uploaded successfully.
Hope this clarifies.