Crash on Request Notification Permissions - Android

Hi,
When I try to run Request Notification Permissions flow on Android (deployed, internal testing) I get crash info (see screen below).

I’m trying to get Push notification working with OneSignal. All is good on iOS.

On Android I can get device token added to the push server and when sent I can see that the notifications are delivered to the device but they never show up on device. In device settings notifications are ON but that is not helping.

When I run Check Notification Permissions I can see they are all false.

Anyone can help?

When I add the Get Device Token after Request notification I don’t get the error BUT I can’t enable the notification permissions on Android. Again iOS working without problem.

I’m trying to change notification settings to True in the Android OS settings but this is not reflected in the app and when I check the permissions all are false.

Hmm… Have you initialized firebase first? Not sure if that is related but I would start checking from there. What version of the SAP AppGyver Preview app are you using?

Hi, thanks for reply. I’m on SAP Android Preview Runtime 4.1.3 and SAP BTP AppGyver Composer Pro build number 3876. But when I deploy app to internal testing I have the same problem.

I connected firebase and initialize firebase flow finishes with success but no change with Request notification permissions flow. Still when I run it I get success but nothing is happening on Android (iOS is ok).

Also I’ve noticed that I can’t connect to debugger anymore but only from Android. iOS is fine. It was working ok just couple days ago. I turned the Release control for one app recently and I don’t know if this have something to do with the debugger connection.

Still no luck with the Request notification permissions on Android.

Could anyone help?

I’ve created separate app just to test and have same issue.


Ticket link: Request Notification Permissions not working on Android | Voters | AppGyver

1 Like