Create Directory flow function

Hi,

@Tomi_Laakso

I am trying to create a folder to store images for my app. I am using for this “Create Directory” with following formula value:

systemVars.fileSystem.directories.android.sdCard+"/MyApp/Media/"

It used to work, but since on my test device the folder was created some time ago, the flow function was always returning true via first output. I have recently deleted the folder on my Android device and creation of the folder seems not to be working anymore. This is the error returned:

image

Questions:
1 Any idea what might be causing this?
2. Does this flow function require Access Storage Permissions? Will it trigger a Permission Request from the user?

Hi, we tried to repro this, but the flow function worked well in every case. Though we didn’t have a phone with a SD card so we weren’t able to try that use case. We’ll check if we can find one to test with.

In the meantime you could try to use phone’s own storage if it would help. Please let me know if that fixes the issue as it can help us to pinpoint the real issue

And to your second question: Yes, permissions are needed and it’ll request those

Hi Tomi,

It is not about SD Card - the systemVars.fileSystem.directories.android.sdCard as per screenshot shows the link to storage directory. You can see screenshots from debugger from 2 phones I am using, both do not have SD Card.

OnePlus6
image

Nexus5
image

Now - a funny thing. I was getting errors on OnePlus6 (via Appgyver preview app and actual build).
I tested it a bit more on Nexus5:

  • I delete folder, open my App (via Appgyver preview app) - the folder gets created no issue, seems to be working…
  • I have uninstalled Appgyver preview app (as this resets all permission) and installed Appgver preview app again,
  • I open my app and instead of creating folder (which happens on the first screen of my app) I get an exact the same message as in the initial post - cannot create directory.
  • no request for access storage permissions at ay point
  • I test part of my app where I get take pictures and copy them to folder - I get request to grant access to photos and storage
  • I close the app and open the app again - initial directory creation works fine!

I think at some stage this flow function stopped asking for permissions to access storage?

Ah, thank you for these details :+1: I think I was able to repro the issue now. And yes, it looks like the issue is that the flow function doesn’t ask for permissions. I’ll let you know when a fix is available.

1 Like

@Tomi_Laakso did you guys had a chance to fix the permissions on this module?

by the way is the Move/Rename/File directory module always asking for permissions? I am getting some user reports that there are some crashes moving around moving the file saved from the camera.

Hi @Greg_F, did you figure this out? I think we published some updates to these Flow functions at some point, so I started to wonder if those helped with your issues

@Tomi_Laakso Hi - yes I have not encountered any issues with permissions anymore. Thanks a lot!

1 Like