Create Post using Airtable as Backend

We’ve been trying to create record for Sign Up function. However, when we made custom schema: 1) Name, 2) Address, 3) Email, 4) Password and run a test for it, the reply would be:

(Error: JSON error response from server: {“error”:{“type”:“AUTHENTICATION_REQUIRED”,“message”:“Authentication required”}}.status: 401

Resource settings for Create record (POST)

Resource URL:
Relative path: undefined)

We’ve also set the relative path for Get Collection(Get) as “records”.

Can anyone help us?

1 Like

Hi You need to include the API key. You will find this in Sign in - Airtable

In appgyver, at data configurator, add this entry to the HTTP header.

KEY → Authorization
LABEL → Authorization
VALUE → Bearer

Also your custom schema should be an object(fields) with the exact same properties as your database schema.

1 Like

Thank you for replying! We’ve actually included the bearer key already. However, when we’ve done it. We tried to run the same test and it says

"Error: JSON error response from server: {“error”:{“type”:“INVALID_REQUEST_UNKNOWN”,“message”:“Invalid request: parameter validation failed. Check your request data.”}}.status: 422

Resource settings for Create record (POST)

Resource URL:
Relative path: "

Also, the field types are the same in Airtable and Appgyver.

Your schema should look like this.

Also does the Get record collection work?

We haven’t configured the Get Record(Get) but we’ve configured the Get Collection(Get) and it runs well, the status is “Ok”. Previously it wouldn’t work but after adding “records” on the response key path, it works now. Our problem is the Create record (POST).

This is the fields in Airtable:

This is how it looks like in Schema:

Exactly. Your schema in appgyver is the problem.

Delete the schema.

Then add a property “fields” which is an object.
Automatically you will see a property id is created. rename it to Address

Then add other columns of your table.

This should work.

It’s still saying the error message even though I made the changes already:

This is how my schema looks like now…or should everything be text?

The field names in the schema should be the exact field names in the airtable. To the letter. I see you hve used name in the schema when your database field is Full Name.

Also note name is not equal to Name. Capitalisation matters.

Thank you! It works now but my problem’s with connecting it to the input fields and generating record into the database… The test run says “Ok” and new records could be found on the database, however, when I’ve input a record and submit it, it won’t work.

I’ve been watching a video on how to make a sign up page and I’ve followed it but it’s not working for me, and I don’t really know what I’m doing wrong.

So, the video says I have to switch from Views to Variable mode and select the name of the API for data variables which is “Signup” and to make another object in page variables which is the same as the one in “Signup”. I just made it exactly alike each other.

This is for the Page Variable:

This is for the Data Variable:

This is the API Create Post schema

However, whenever I try to create a new record, it records only the number “0” under Phone Number.

This is what I did:

I’ve put the values on the input fields for the page variables.

Text Input items > Properties > Values = Page variables (ex. signup.Address)

and I’ve put the values on the sign up button for the data variables.

Sign up Button > Logic (Create Record) > Properties > Resource Name = Data resources & Record Properties = Data variables.

You don’t need to use data variables for creating a new record. The creat record flow function directly writes to the database you select.

Then you need to assign the values you want to store in the database.

You are doing nothing wrong. Just missing a step. When you create a record, the flow function needs a set of values. You aren’t providing those. Since phone is a number, its default value is 0. That is the reason you are seeing only that.

If it still doesn’t work you can hop on a zoom call and we can figure it out.

Is this the correct way of assigning values in the database?

I’ve put the page variables inside the object with properties fields.

Now it just shows this whenever I try to submit the records

Phone Number should be a Text, not a Number

@PRAJWAL_SHARMA @Edgar_Ramores -
I see your post very much similar, can you help where am I going wrong ? I am trying to create record as well -
Appgyver API - Fields + Properties

Appgyver Schema -

Airtable -