Custom font not showing in build (android)


My custom font is not showing up in the built version of my app (android). It does however show in the preview app. I uploaded the font in .ttf format (also tried url) and set the theme variables to my custom font.

Does anybody have an idea what goes wrong?

my custom font isn’t showing up in the build either (web, 2.4.28).

Same as OP, they are showing up correctly in preview.

Hi! I’ve tested with 2.4.33 and don’t seem to have problem with this anymore – can you verify if you’re still experiencing this issue?

Hi @Mevi,

We are building a web app in AppGyver, and are still new to the platform. For a few weeks, we have been doing web builds with the client runtime version 2.5.12. Yesterday, we noticed that when we go to the build service to create a web app, it only allows runtime versions 1.9.26 and 2.6.7 (which leads to some custom font issues).

In our app, we use the Material Icons Font (Outlined) for icons in our (web) app. This font works by typing an icon name in a paragraph or title with its font family set to the Material Icons font.

A few weeks ago, however, when we attempted to build our web app with the latest client runtime version at the time, we noticed the icons displaying as the plain text icon names, rather than actual icons, indicating that the custom font wasn’t working.

We solved this problem by using client runtime version 2.5.12 (a slightly older version). In this runtime version, the fonts displayed perfectly! We are inquiring because at the moment the font appears as it should in the preview but not in the web build at [APP NAME] You can see that without this font functionality, it produces some unpleasant-looking bottom bars like the one below in our web build:

, rather than in the web preview:

We identified this discussion thread as appropriate, although the thread title is specific to android, because of a post by @Tyler_Phelan

Maybe this could be fixed temporarily if AppGyver restored runtime version 2.5.12 in the meantime until this is fixed in the latest version? Thanks!

Hi! Sorry for my belated answer, I’m not able to spend that much time on the forums these days I’m afraid. Thanks for reporting this, we’ll look into it!

Hi. Was this resolved?
I am experiencing the same issue. The preview shows my custom font, but the build using the latest client runtime does not display it.
Please assist.

@Mevi I am facing the same issue with 3.0.5 build version did you find any fix for this

Hi! There shouldn’t be any issues that I know of :thinking: On which platform (iOS/Android/web) are you having issues? What is your font name? (at some point fonts were broken if they had a space in the file name).

EDIT: asked around and apparently there’s a known issue with fonts with a number in the name or file name not working, so check if you can rename your font to be with letters only, without any special characters or numbers or anything and see if that works.

I am using Android and I am using custom font “Poppins” downloaded from the google apis .It is working fine on the preview screen. Also I am using the shadow but it is not visible in the production Build