Custom fonts are not showing in the IOS build

Hi,

I published my app to the apple store and to my surprise, almost everywhere, my customs fonts are not showing.

They appear as default fonts!

I cannot figure out why, as their settings are the same than in the places where it works.

That is surprising because the fonts are fine in Android preview, fine in Android build, fine in web app, and even fine in IOS preview!

What could cause that ?
Are there compatibility issues with fonts on IOS ?

Also, my GIF in not showing on IOS build, but is working everywhere else… how to fix ?

Now I know about the problems with space and numbers in the fonts name, but that is not the issue…
I also uploaded the fonts with the matching weight parameters.

App Id: 159712

(upload://oxOJ1AczOcFNSGclrCrdzkICOTl.png)


.

Capture d’écran 2021-10-31 à 15.06.59

Hi! Are you still seeing this problem? What version did you build with?

Hi Mevi,

Yes, I am still experiencing this issue, also discussed in the issue tracker here

I tried with 3.0.5 and 2.12.4 with the same result.

I even uploaded new fonts to try, and they are not showing on Iphone.
Only 2 fonts are working.

This issue is only with the IOS build, it is working fine on Android and on the previews.