Custom header lock

Does anyone know if its possible to lock a custom header in place, so when you scroll it stays put?

You set its position to ‘Absolute’ at Top = 0

@Dimos_Vamvourellis Sticky and Fixed component parameters aren’t (yet) supported on Appgyver. It sounds like you want a floating custom header that always remains in the same position like this:
chrome-capture (2)
(Click the image to play the gif)

We’ll have to hack it a bit in Composer with scroll views. I’ve covered that here:

Also, see Post #5 in the thread for additional steps you’ll need to take to make it look right.

1 Like

what i wanted is to not move when scrolling
But thanks

Thank you very much i will implement it !!

1 Like

Unfortunately, an Appgyver bug just popped up which has broken this function in the short term. Once they fix it, it should work fine for you. More information here: Bug: Disable Scroll/Full-page scroll views not functioning properly

1 Like

ohh ok we can wait and see

@Dominik_Greene @JOHN_WORSHAM
hey
has anyone got any feedback because mine still doesnt work…

Hey, @Dimos_Vamvourellis, there are a couple of threads on this now. It’s holding everyone back who’s working with custom headers and the like at the moment. The closest thing to an update might be Mari’s recent post in a different thread – but still no telling how long until a fix is pushed through. They seem to be quite swamped. If you can work around it for now, that might be best.

1 Like

4 October and still no fix for this?

+1, i believe its an important feature that is still not working .

1 Like

Thanks…
Hope someone fixes it soon.

It is partially working in the repro app I built quickly for the team, but still has plenty of issues. Harri said on Slack about six days ago that they were working on fixing this for good. We’'ll see. When so much of our web app requires custom popups and floating/sticky component, this really kills the morale in the team.

1 Like

Good news! It’s mostly working again. Just a double scroll bar effect on desktop browsers. Good enough to get back to work. They’ll probably patch out the rest by the end of the week,. :slight_smile:

@Dimos_Vamvourellis @Martin_Herbst

I take that back. It’s now fully working again. If you have the double scroll bar issue, this is an unavoidable bug that occurs depending on your browser’s zoom level – specifically, in the Web Preview. I’ll post a screenshot of what I wrote on the Slack for some context:

Correction: For me, the double scroll bars ONLY occurs at 100% zoom. All other zoom levels render properly. Have at it, folks.

Hi there, im i doing something wrong her, because i think it still doesnt work properly.
I think that the upper part shouldn’t move.


Also maybe you cant recognize from the video bellow, but the side scroll still doesnt work properly…

Hey, @Dimos_Vamvourellis. One thing I can say is that one should almost always tick the “Stretch to the viewport height” checkbox visible at the middle-right of the image you shared. It’s at the bottom of the Style tab for the Page Layout. No idea if it’s relevant to native apps (as we’re doing a web app for desktop and phone browsers), but it’s usually been necessary to tick it in my experience.

Some other small things you can double-check:

  1. Is the “Header container” set to absolute positioning instead of relative, with a higher z-index?

  2. Is your scroll view set to 100% height and width, respectively, with no min/max heights set?

** As for the horizontal scroll view, I haven’t used those at all, so I just jumped in, set up a fresh scroll view, went into the component’s Properties tab and set Horizontal Scroll to True, and populated a few image components inside. Tested it in the Web Preview on desktop (versus the Appgyver/SAP Preview App for mobile devices) and it worked fine. Only annoying thing was that the horizontal scroll view still stacks the objects vertically in the Composer editor.

That’s all I can think of off the top of my head. It’s getting late, so if you respond, I’ll probably be back around beyond the next 12 hours. Double-check these things above because the header matter is actually a fairly simple process and I’m drawing blanks on anything else.

Wooo i wasn’t expecting that but just checking the stretch to viewport box fixed the problem, as for the horizontal scroll i will look more into it and let you know,
Thank you soo much for your help!! @Dominik_Greene