Date field hides behind other fields in portal mode

I am stuck while trying to configure the Date field as it keeps hiding behind whenever it is opened while in preview mode for Web Portal. The same field works properly in mobile mode. I am not sure which settings to alter to get the same result in the portal mode. Below are the screenshots for reference.

Web Portal:




For this component, you’ll have to go to its “Layout” tab, and set the z-index to some larger number, for example, 10. This will make the date field show up on top of every other component, unless you have other components that you’ve manually set the z-index for.