Date formats not valid for sending through mobile

Hi,
I have an app that is very basic that is sending a value from the date Picker component to an API end point. when I test through the Data View, it works and when I test it in the web client it works.

However when use the same functionality through the mobile client I am getting JSON error response {code:8003, message:Invalid date format, errorData:{}}

Has anyone experienced this before or know how to remedy it as I cant get it to accept any format currently through a mobile solution.

The date is a datetext in all elements.

Thanks in advance

Which date picker do you use exactly?

You might try more options to enter the date, like

image
2.


3.

I am using the options 1 and 2 and distinguish by and IF-node with a
’ systemVars.runtime == “web” ’ condition:
image

The option 3 was released after I had my setup done already, but it is supposed to be the easier way, as it is made to work for both (web and native).

Yes, it is option 3 that I am using.
image

Aside from ordering issues on the web display where I get this type of display:
image

This is the data value being submitted, which seems correct:

But I get this response :

The failure is only on mobile though - on web it processes correctly every time.

For the UI, you have to set the Z-index of the date field so that it will appear correctly on top of other components – this is an issue that has not yet been solved on the runtime side so this workaround is needed for the time being. …I did add that information to its description, but that’s not visible anywhere :thinking: I’ll add a fix for that.

EDIT: also apparently the mobile version’s timestamp did not include milliseconds and while this should not be a problem as it is a perfectly valid datetime value… it might be for your backend. I put a fix coming that the timestamp for mobile will also include milliseconds :sweat: working with datetimes is… complicated.

1 Like

Hi Mevi,

For the UI, you have to set the Z-index of the date field so that it will appear correctly on top of other components

How do I know what the Z-index should be set to?

You can ignore this question. My issue was that the container was clipping overflowing objects, so had to change that setting.

1 Like