Embedded map view (beta) seem not working properly when an application was distributed to Play Store

I just distribute my application which using Embedded map view (beta) to Google Play Store for testing.

On review time under AppGyver application, a page on my application which contain Embedded map view (beta) seem working fine as what I need. However this same page that contain Embedded map view (beta) could not be open on my distributed version downlod/install from Google Play Store as it immidiately close my application.

Please advise.

You need to have the google-maps and react-native-maps plugins in your build configuration under the Plugins tab – looks like there’s a bug that these are not automatically added to your build config ATM. If you add them manually and rebuild it should all work.

There are no Plugins tab found on my build screens.(see attachments)

Please advise.

Right – those are hidden for regular users, sorry for the wrong info! I updated the Embedded map component now with the additional google-maps dependency for Android, can you try updating the component, saving the app and requesting a new binary from build service and seeing if it works now?

I am now update component version then rebuild it however I think there are some bugs on Build page.

  1. “Package identifier” seem not be built as a value I set on “ANDROID BUILD SETTINGS” -> “Bundle Settings” and it displayed incorrecly on Google Play Store. (ie. I set as com.mycompany.totemattendance but when it built it always as com.totemattendance.app)

  2. “Version code” and “Version name” seem not be built as a value I set on “BUILD” page but it seem displayed correctly on Google Play Store. (always 1.9.2, see attached picture)

There was a issue regarding bundle settings recently, You might need to reset them.

The version seen on that image refers to the build client version and not your apps.

How to resit them?

Please advise.

You tried to change the identifier in the bundle settings and saved the changes?

  1. Yes, I update those values under “Bundle Setting” as refer on my previous replied but not work.

  2. I update Embedded map view (beta) component this morning then rebuild my project and upload to Google Play Store. on my distributed version downlod/install from Google Play Store both reinstall and update from old version but it doesn’t work as it still immediately close my application when MAP page was called.

Thanks for the report, we’re working on fixing this now.

Thank you for your service.

This should now be fixed, can you try building an APK one more time?

Following your advise, I just try to re-build for APK files (try twice as I’m not sure may something wrong on the time I do first built) but seem something went wrong as it always on queued for more than 5 hours that normally it didn’t take too much time like this.

Please help.

We’re facing some issues with Build Service, see https://status.appgyver.com – queuing a new build should work better now.

  1. Testing from APK file generated from your system, Map page using Embedded map view (beta) still could not be open on my distributed version.
  2. “Package identifier”, “Version code” and “Version name” problem also didn’t solved.

NOTE: I see below message on your build page so I understand that I could not do more build from now on for the time be.
IMPORTANT! Web builds are currently disabled.
We are investigating the issue. Follow it here!

The web build issue is now fixed, but for the other things, we need to still dig a bit deeper – sorry for the hassle!

Just rebuild then test from APK again now but seem got the same results and same problems.

This needs some further development on our build service. It’s on my list.

1 Like

Hello,

Just used the Embedded map view (beta) on my project and got a problem, the map is showing perfectly under the AppGyver application, but it is not showing the map on the distributed version from Google Play Store.

Was this problem solved?

If not, wasn’t it better to “hide” this tool until all things are solved?

I’m using the updated version of Embedded map view (beta) and I notice that there is a new tab called “advanced” with some google maps keys. I tryed to reset them, but it keeps the same values. I don’t know if I need to paste these keys in another place.

Att,

Meu Porteiro

Did you try pressing save on the advanced tab and building again? Could be that you still need to save these api keys to your build configuration.

1 Like