Failed to Fetch X-CSRF-Token using the HTTP Request Flow Function

Hi All,
I am trying to send a POST request to my SAP system, for which I need a X-CSRF-Token.
I am using the HTTP Request Flow function. I could see in the developer tool the x-CSRF-Token is fetching correctly, But as the response of Flow function I am getting Response Header as empty . I have tried assigning the response to a variable using Formula
outputs[“HTTP request”].resHeaders.map[‘x-csrf-token’].This also didn’t worked.
Can someone help me to solve the issue.

Thanks,
Anjaly

Can you post more detail about the requests the return of the request, etc.?

Screenshots would help, if possible.

For the HTTP Request I am setting the GET URL the base url used in REST API and 2 headers Authorization object and X-CSRF-Token.
image

I am able to get the request response body. But in Response headers I am getting {}.I am trying to set the response of HTTPS Request to a variable with Formula
outputs[“HTTP request”].resHeaders.map[‘x-csrf-token’]

In developer tool I can see the request is fetching X-CSRF-Token

How are you parsing/storing the results?

Make sure that the variables you’re trying to store to are typeset correctly. I’ve found that AG can be difficult with this (especially since some of the AG variable types don’t match what languages, frameworks, and codebases necessarily look for), and it’s often best to set the variable receiving data from a Request as “any text.” Once you receive the data into an “any text” variable, you can parse it into whatever format you want/need.