Firebase/Firestore 403 Error

I am trying to load up my Firestore data in the app preview and am met with the basic listing claiming No Data Available, so I checked the Dev Console and noticed that when fully expanded looks like the following.
403 Error

I have triple checked my Data Connecter base config, android config, and web app config, and they are all 100% accurate.

My Firestore is also supposed to be allowing all Reads/Writes.

rules_version = ‘2’;
service cloud.firestore {
match /databases/{database}/documents {
match /{document=**} {
allow read, write: if true;
}
}
}

Hi @Ethan_Hagan, can you see data from the endpoint if you try to reach it at

https://firestore.googleapis.com/v1/projects/reptile-tracking/databases/(default)/documents/collection-name , replacing “collection name” with the name of the collection you have?

There is a suspicious-looking extra spacebar character in the configuration, since the consumer is "projects/ reptile-tracking"

1 Like

Yes, I can see the collection from that endpoint. I found the space and removed it, but I am still receiving the same error as before. I completely closed and re-opened any AppGyver windows, to no avail. I have even attempted loading with Cache disabled and after clearing the cache.

Okay, haven’t seen this before – could you provide me with your app ID (number sequence in project URL) so that I can take a look at the issue? Also if the app requires login, could you send me the details via private message.

1 Like

@Mari There is no authentication yet. The ID is 369995

Hi @Ethan_Hagan, looks like the change in collection name is not registered, and the spacebar character persists in the URL even though you removed it from the config.

I got it to work by recreating the “Reptile” resource from scratch with the same definition and schema.

image

Thank you so much, I noticed the space was still there, but wasn’t sure what to do when clearing the cache would not work.

1 Like