Firebase integration error

Hello folks,

I’m getting a Firebase error I can’t figure out for the world! I have a “Create Record” node to, well, create a new document on Firestore DB.

I already verified data types like one hundred times to make sure they match, it is all good. I also tried passing the information through a Data Variable and directly in a custom object. Sometimes, not always, when I keep one or another (randomly) property with “no value”, it works like a charm for a few times and then, with no intervention in the app, the same error again…

My last move was to integrate to Firestore as a direct REST API. On Data Tab testing it worked perfectly, when tried to make it in the logic flow… Guess what?! The same error. After that I figure I must be doing something wrong and I think it’s something really fool, but I just can’t figure it out!

Just to finish - already tried to erase everything and redo, pass data as object, mapping, formula… nothing worked.

Any advice will be greatly appreciated! Really!

The value passed is:

  "value": {
    "record": {
      "comment": "test",
      "goal_id": "4c3XmFCBULfiLI5yUoIA",
      "user_id": "aovJ8QZ6kthyVVsYVtC6",
      "is_reply": false,
      "goal_name": "This is the Goal Name",
      "is_toplevel": true,
      "created_date": "2022-03-21T16:56:43.798Z",
      "comment_replied_id": ""
    }```

For the answer I keep getting:

```{
  "code": "requestFailed",
  "status": 400,
  "message": "INVALID_ARGUMENT: Cannot convert firestore.v1.Value with type unset."
}```

Looks to me like your schema isn’t right, as the types are missing (e.g. stringValue).

You can use ‘run test’ and ‘set schema from response’
image

Thanks for the idea!! Actually, that was literally the first thing I did… using the Test feature inside data configuration works great and the schemas are perfectly set, but when using the app the error keeps happening.

Let’s reduce the complexity and see step by step what works :wink:

What do you see, when you click on ‘custom object’ like in the following screenshot?

image

1 Like

Hi, I’m getting this error, too. The schemas match on both sides. A simple, tiny document type of string, number, number.

Help! :slight_smile: